WordPress.org

Forums

[resolved] [Plugin: W3 Total Cache] Won't configure with Origin Pull Cloudfront CDN (4 posts)

  1. Evan Spielberg
    Member
    Posted 2 years ago #

    This probably straddles a few topics but I’m currently having trouble setting up Origin Pull with W3 Total Cache on Amazon Cloudfront.

    Whenever I click Create Distribution in the CDN Configuration of W3TC it doesn’t create anything in Cloudfront. When I click test it fails.

    Currently it has the origin listed as my EC2 host name, which for the moment is the siteurl and home of my blog, I’m not ready to deploy it to it’s eventual .com yet.

    Thus a follow up Question: Why can’t we change the “Origin” in the W3TC config if we’re using origin pull?

    Originally I had configured a Cloudfront Distribution and Origin on my own, but there’s no where to select that in W3TC. After reading a different support post I disabled that one in hopes that re-clicking Create Distribution in W3TC would create it. Should I manually create a distribution with the origin listed on the W3TC CDN settings page?

    Quick background
    My entire infrastructure will be on AWS.
    I have WordPress running on an EC2 instance with RDS as the server.
    I plan on allowing multiple EC2 servers for load purposes.
    I have an Elastic Load Balancer which will be where my DNS points to eventually.

  2. Evan Spielberg
    Member
    Posted 2 years ago #

    OK Interesting update. I went into Cloudfront and created a Distribution with an origin that matched what W3TC had on the origin line. I clicked create in W3TC and it said Creating... which it said for a little while, I clicked test and it said Test Past.

    This is still different from what my URL will be when I finalize everything for full deployment.
    Everything is CNAMED but I'm wondering if any of this matters?

  3. elihub
    Member
    Posted 2 years ago #

    I've had the same problem this... clicking 'Create distribution' just leaves 'Creating...' hanging there, but when you click 'Test CloudFront distribution' you get 'Test passed.'

    However, there's nothing in the cloudfront subdomain field, which throws an error at the top ('Replace default hostname with' fields must be populated').

    Thoughts?

  4. minitvstick
    Member
    Posted 2 years ago #

    Hi there, was this problem ever resolved?

    I find that I have the same problem. Just hangs on "Creating..." and then nothing is created on CloudFront...

    I am running WordPress 3.5.1
    And using W3 Total Cache 0.9.2.8
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic