WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » [Plugin: W3 Total Cache] What am I doing wrong?

[Plugin: W3 Total Cache] What am I doing wrong?

  • For some reason my site is loading slower when using W3TC than without. A quick check on pingdom.com shows an over 15 second page load time.

    I’m on a dedicated server with 8 gb of ram. At this moment I only have page cacheing and browser cacheing enabled. (although I’m not sure if the options I’ve checked in there are the best..)

    I was told by one of the developers of this plug in not to use database / object cacheing unless I had Opcode enabled. I talked to my server and they said they would install it for me, but that it wouldn’t work with suPHP and they wanted to know if I had any suPHP modules on my site. I honestly have no idea. I wanted to see if anyone knew of a way I could tell.

    Also I currently have minify off, because some people that use the same wordpress theme as me said they were having problems with it. Then they said if you used manual mode instead of automatic it would work. I don’t know enough about what minify does to try it out. Do you suggest trying it? I’m using a child theme, does minify work with wordpress child themes? there are so many “walk throughs” online and all of them contradict each other.

    I would appreciate any advice. Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m not sure why w3tc would be making it slower, but currently it looks like most everything on your site is loading really quickly, it’s just that you’re loading a million different files, and they’re all stacking. The fact that you have ads from multiple networks doesn’t help either. The more external content you’re loading, the less control you have over optimizing the load time.
    When I ran a pingdom test, it was more like 4-5 seconds, which is still more than it should be.
    Definitely combine and minify the css. What you want to do is view the source from your homepage (ctrl+u on chrome or firefox), and then hit ctrl+f to search for any .css files. Now copy the path of each file in the order they appear in the source into the minify tab.
    You seem to have a lot of js files, so I would do the same thing, but those can be a little more tricky to get right if you don’t know what every script does. You might want to try just installing a js to footer plugin to see how well that helps.
    If you do the js minify, add them one at a time and then check to see if it broke anything before moving to the next.

    If you just chose combine only, it would help quite a bit.
    I would also use a lazy loading plugin to make sure the images don’t slow down your load time.

    oh,and yes, everything works equally well whether or not you’re using a child theme. Most of my installs are using child themes.

    Hey thanks! What are your thoughts on installing opcode?

    Also on the minfiy seetings, what about the following options:

    rewrite url structure?

    html/xml – inline css, inline js, don’t minify feed, line break removal. Should I check all/none/or some of those?

    Under js setings what should I check?

    In js file settings I can select my theme or my child theme theme…but it seems like I would somehow need to select both, unless by selecting my child theme it’s almost pulling the parent theme info..

    same questions for css area..

    What boxes to check, what to use for import theme, etc…

    Thanks.

    I’ve only ever dealt with shared hosting, so I can’t comment on opcode

    Here’s what I have on my settings:

    general/html/xml
    “rewrite urls” means the minified file will show up in the html like this:
    wp-content/w3tc/min/b8ed3/default.include.e931ab.css
    instead of this
    wp-content/w3tc/min/index.php?file=b8ed3/default.include.e931ab.css

    the first one can be cached and mirrored by a CDN, and the second one cannot, however there are some cases where rewrite url’s won’t work, so you’d want to disable it. I’ve also seen the error that it’s not working when it actually is. If you view the source and copy the path into you address bar and you can access the file, then it’s working.

    For the theme, select your active theme, which would be the child theme. (not sure why sometimes (active) is next to a theme that isn’t active).

    then, just click the “add a stylesheet/script” button and add the path for each file.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: W3 Total Cache] What am I doing wrong?’ is closed to new replies.
Skip to toolbar