WordPress.org

Forums

W3 Total Cache
[resolved] w3 Total Cache page chace issues and other problems (6 posts)

  1. tobi1kanoby
    Member
    Posted 3 years ago #

    Hi all,
    I have been trying to figure out ways to speed up my site.
    makemoneyim.com
    I have read numerous w3 total cache set up tutorials and have implemented most of them yet I'm still facing some issues.
    I ran a test on http://www.webpagetest.org and have found out some issues:
    Combine static CSS and JS files: 0/100
    Use a CDN for all static assets: 36/100 the majority of failed files are other plugins and theme files.
    Leverage browser caching of static assets: 54/100

    When checking the compatibility check of I have found the following issues:

    Opcode cache: Not installed
    Memcache extension: Not installed
    HTML Tidy extension: Installed (required for HTML Tidy minifier suppport)
    Mime type detection: Installed (mime_content_type) (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    set_time_limit: Available
    mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)

    Additionally The page cache set up displays two warning messages:
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I have contacted my host ( bluehost) and was said they're set up is fine. The htaccess. file's permission is set to 664.

    Running a yslow check I have an F for add expired headers although I think I have set it up fine, and an F for putting JS on the bottom

    There are a few other issues but this is more than enough to start with.

    Any help would be more than welcomed.
    Thanks
    Tobi

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. haddow777
    Member
    Posted 3 years ago #

    Let me just say that without the rewrite ability, your not going to get much functionality. Does your host actually use Apache. I have a shared hosting account with one company and I don't think they use Apache. Also, your host might say there setup is fine, but did you ask if they have those plugins installed and running (I would find it hard to believe they don't though.

    Also, what version of PHP is your host running? I know that some features won't pass tests if it isn't PHP5. I don't think all your problems would be due to it, but again, I have never tried to run W3TC on php4, so I'm not sure of the differences.

  3. nosilver4u
    Member
    Posted 3 years ago #

    I'm on bluehost too (haven't contacted support yet), and have similar issues with the compatibility check. They definitely have mod_rewrite available, and they definitely support .htaccess rules, but W3TC seems unable to detect this. As far as I can tell, W3TC is actually functioning, although I haven't done much more than run Yslow (A) and Pagespeed (96/100) to verify the changes. I have minify set to just combine files, since it didn't seem like it was doing much cleanup, so I've got cloudflare doing that part, and it works peachy. Any ideas?

  4. nosilver4u
    Member
    Posted 3 years ago #

    just confirmed with Bluehost support that those Apache modules are enabled on their shared hosting servers. something with the way they run things that makes them 'undetectable'. Perhaps some sort of stealth mode to avoid vulnerability scans that want to find enabled functionality.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    I've successfully set up folks on bluehost before, they're servers are definitely compatible. Anyone having issues here should submit a bug submission form from the support tab of the plugin.

  6. tobi1kanoby
    Member
    Posted 2 years ago #

    Will do Frederick.
    Thanks for your support

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic