WordPress.org

Forums

W3 Total Cache
[resolved] W3 Total blocks (404) WP-Seo's XML sitemap although added it to exclus (15 posts)

  1. iceq
    Member
    Posted 3 years ago #

    Two days of attempts and I never managed to have Yoast's WordPress Seo plugin's XML sitemap feature work.
    I keep getting 404 error trying to access it.
    I added "sitemap(_index|[0-9]+)?\.xml" to both options in W3 Page Cache:
    Never cache the following pages:
    and
    Cache exception list

    (whats the difference between them anyway) ?

    I am still getting error 404 on a page from my Hosting, not from my blog !

    I disabled the Page cache module of W3 Total. Nothing changed
    Then I disabled the whole plugin, and this time I still got the 404 error but on a page from my blog, not from my hosting.

    I added this to the htaccess file that's inside my cursed WP installation's directory, (AFTER the default htaccess rules)

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix

    That did not help either.

    I am having this on all my blogs (all have W3 Total). What could be the reason ?

    Thank you

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. SuperFastCars
    Member
    Posted 3 years ago #

    You should give one of the sites so we can look at it?

    Latest version of WordPress? SEO by Yoast plugin version?

  3. iceq
    Member
    Posted 3 years ago #

    Thanx SuperFastCars. Yes its the latest version of WordPress and latest of Yoast's plugin.
    I disabled the plugin on the blogs , that's why I did not provide a link to any of them .

    But it just gives the error 404 ( I mean there's nothing really to see)\

  4. JPS Autosport
    Member
    Posted 3 years ago #

    Hello,

    I just noticed my sitemap wont work and gives a 404
    I use lates version of WordPress, Yoast and WP Super Cache.
    If you need a look at my site http://www.jps-autosport.nl

    Can you help me out?

    Jasper

  5. Marc
    Member
    Posted 3 years ago #

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+)?-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix

    That works. The question mark was in the wrong place.

  6. JPS Autosport
    Member
    Posted 3 years ago #

    Thanks,

    This goes in the .htaccess above everything?
    Just tryed and it works fine
    http://www.jps-autosport.nl/sitemap_index.xml

    Great support,

  7. bauhausweb
    Member
    Posted 2 years ago #

    In order to get the xml sitemap to work I had to configure my W3 page cache settings this way:
    1. "Never cache the following pages:" - enter all .xml URLs in this field
    2. "Cache exception list:" - do not add the .xml URLs here
    3. "Non-trailing slash pages:" - remove all entries from this field

    Now it works, the W3 Total Cache + WordPress SEO's xml sitemap feature.

  8. baweibel
    Member
    Posted 2 years ago #

    I did exactly what bauhausweb suggested and not I have a 500 Internal Server Error for the front and backend of my site. Can still get in FTP so tried deleting the W3TC plugin entirely but that did not help. Uploaded it from a backed up copy on my local hard drive, again no difference. I am completely dead in t[he water and have no idea what to do. Is there anyone out there who can help me? Site is http://holeinthedonut.com

  9. bauhausweb
    Member
    Posted 2 years ago #

    Hi baweibel, it looks as if you have a classic .htaccess problem. Try this: log in with your FTP, look in your main root folder for a file called ".htaccess", open it and place a "#" in front of each (!) line of code so it looks like this:
    "# <Files wp-config.php>
    # order allow,deny
    # deny from all
    # </Files>"

    P.S.: In case you cannot edit the file on-the-fly within your web host and you gotta download it to your desktop, make sure that the file has a dot in front of the file name when saving it: .htaccess

    Is your site accessible again?

  10. baweibel
    Member
    Posted 2 years ago #

    Hi bauhausweb. Thanks for the reply. Not up yet - I've downloaded the .htaccess file and am adding the hash tag, but have a couple of questions. I have read up and realize there are some other files I need to remove in the wp-content folder in addition to the plugin itself. Should I do this before I upload the modified .htaccess file? Also do spaces matter with the hash tag (is it OK to leave a white space between the hash tag and the first letter)? Your example shows it both ways and I want to be sure I get it right.

  11. baweibel
    Member
    Posted 2 years ago #

    bauhausweb - I'm thinking this is beyond my ability. Looks like some of this code in the .htaccess spans multiple lines. When there are < > opening and closing the code, I can tell where it begins and ends. But in some places without I can't tell. Do I just put the hash mark in front of every line, even though it might be in the middle of a line of code?

  12. bauhausweb
    Member
    Posted 2 years ago #

    Hi,

    the best way to open such file is by using Notepad++ (open source). Google this, download and install it and open the .htaccess with it.

    Once open, place the hashtag + <space> infront of each (!) line, e.g.:
    # .....
    # .....
    # .....

  13. baweibel
    Member
    Posted 2 years ago #

    OK, I uploaded the .htaccess file and tried to remove the following files using FTP:
    wp-content/advanced-cache.php
    wp-content/db.php
    wp-content/w3tc/
    wp-content/w3-total-cache-config.php
    wp-content/plugins/w3-total-cache/

    Successful in all cases except wp-content/w3tc/ Says access denied. Tried setting permissions to 777 but wont let me do that either. Now I can see my home page, but any other page gives me a "not found" error, and my back end gives me the error: "W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /var/www/vhosts/holeinthedonut.com/httpdocs/wp-content/object-cache.php." Tried logging into Plesk but that also gives me a 500 - Internal Server Error.

    I do appreciate all your attempts to help - any other ideas?

  14. bauhausweb
    Member
    Posted 2 years ago #

    Why did you delete these files?
    First of all, in case you want to/need to get rid of a plugin by deleting files (in opposite to uninstalling it properly), you only delete the plugin folder under .../wp-content/plugins/name-of-the-plugin itself.

    Can you restore them? Do you have a proper backup of your website?

  15. baweibel
    Member
    Posted 2 years ago #

    bauhausweb, with any other plugin I would agree with you, but notoriously, uninstalling W3TC does not get all the files. The developer recommends uninstalling all those that I listed. I do have a backup of the database and core files but not sure I have all the W3TC cache files.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic