W3 Total Cache
[resolved] Updated to 9.2.4, "You do not have sufficient permissions to access th (8 posts)

  1. whatsthatbug.com
    Posted 5 years ago #

    This is odd. I upgraded to 9.2.4, and now w3tc does not show up as Performance in the bottom of the left column, and if I try going directly to the options page I get the error "You do not have sufficient permissions to access this page." I am logged in as administrator, same as always. Has anyone else had this happen?


  2. kathywhatley
    Posted 5 years ago #

    I got the same error message about not having sufficient permission. The plugin was deactivated. I activated it again, but now on the Dashboard under the Incoming Links section I get this:

    Fatal error: Out of memory (allocated 27787264) (tried to allocate 18 bytes) in /home/wridcl/public_html/downloadformovie.com/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php on line 751

    Also, I made a change to the layout of my theme and the change is not showing up. I have emptied all caches, but it is still now showing the change on my site and that was around ten to fifteen minutes ago.

  3. kathywhatley
    Posted 5 years ago #

    I am using the Swift theme if that makes any difference.

    If you need it my site is: http://www.downloadformovie.com


  4. Jawillde
    Posted 5 years ago #

    @Whatsthatbug.com, kathywhatley has your answer. Same thing happened to me. Make sure the plugin is activated after upgrading.

    @kathywhatley, we run the Swift theme and have had no issues. You may need to increase the php memory limit in the php.ini file. You're looking for a line that looks like this:

    memory_limit = 8M

    Increase it in increments until that 'Fatal error:' no longer appears.

  5. whatsthatbug.com
    Posted 5 years ago #

    That is indeed what happened - the plugin did not reactivate after updating. Thank you!

  6. kathywhatley
    Posted 5 years ago #

    Well somehow everything seems to be working now. I didn't do anything. And Jawillde FYI, I could not find a file called php.ini. I looked on the Swift files and in the file manager and did a search but it came up with nothing. Thanks for trying!

  7. Gilligan
    Posted 5 years ago #

    Log out and log back in, refresh the admin dashboard a couple of times and you should be good again.

  8. frg
    Posted 5 years ago #

    yeah had similar glitches of "You do not have sufficient permissions.." and self de-activation after i did the requiered .htaccess updates. but then re-activatated & everything is fine now - i even have the feeling it works faster than ever!

    webpagetest.org confirms that.

    i m on wp 3.2.1..

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic