Support » Plugins » [Plugin: W3 Total Cache] Update theme

  • Hi,

    I updated my style.css file recently. When I checked my site as a logged user (logged user are not served a cache version of the site) I’m seeing the changes. But when I checked the site as it is being served through my CDN, the changes are not there.

    I did went to the plugin menu on my Dashboard>Performance>CDN and uploaded the theme file again so the newest modifications would appear. I’m using Amazon CloudFront. Also, on my installation Minify is disable.

    The theme file being served through my CDN is compressed version: style.css.gzip

    Should I “purge” object from my CDN or wait a little more (and yes, I empty the cache of the browser I’m using to see in the changes are taking effect)? Or is there something else I’m missing?

    Thanks for any tips,


Viewing 9 replies - 1 through 9 (of 9 total)
  • I recommend enabling “Prevent caching of objects after settings change” on the browser cache settings tab to make it easier for changed files to be correctly downloaded.

    Hum. I tried it but then the whole website won’t load through the CDN. I will load only if I ask to be served directly (without the cache), as an administrator for example (I’ve asked for the administrator not to be served a cache version: more practical for maintenance).


    A quick follow up, as this is a serious issue (I can’t modify my theme under my current settings, unless I completely disable by CDN):

    1) I tried to purge my style.css file without effect.

    2) It was suggested to me to created version of the file and allow query strings from by CDN. I guess it’s a solution, but I would love to use a way native to W3 Total Cache to solve this issue.


    This will need to be investigated further. Can send a bug report from the support page in the plugin?


    It’s done, I sent a bug report.

    Please note: I also tried to invalidate the style.css file from my AmazonCloud Front console without effect.


    Follow up:

    From the “General Settings” page, when I try to “Purge cache” in the CDN field, it systematically fails.


    Follow up:

    The problem does NOT concern all files hosted by the CDN. I made some changes to the footer.php file and after I “purge all cache” it took effect: the changes were correctly served by the CDN. However, changes made to the style.css file still refuse to change.

    I’m having a similar issue. I’m on CloudFront as my CDN… my theme CSS is not minified but is using gzip compression. The file on my CDN is app.css.gzip – I see that my app.css is purged but not the gzip version in use on the site. It would be great to get this working.

    @devin: I suggest you start a new thread and/or send a detailed bug report through the plugin interface.

    It happened to me two times in a year. Each time, the problem disappear within 48 to 36 hours, but I cannot pinpoint why: during this interval, I tried many things, including purging the file from the CDN, emptying cache, etc.

    One thing you could do is to use a web inspector (in whatever browser you’re using) to see where the style element you’re being served is coming from. You have to make sure the changes were added in the cache version of your site and that you’re being served an updated cache version (not an old cache version where the change doesn’t exist). Logging out of WordPress and using a different browser (one you don’t usually use) maybe of some help.

    This is some info you may add in the bug report.


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: W3 Total Cache] Update theme’ is closed to new replies.