Support » Plugins » [Plugin: W3 Total Cache] Undo 302 Redirects

  • Tried installing W3 Total Cache earlier and enabled CDN (used self-hosted option) but after it didn’t work, I disabled it and used the plugin without the CDN capabilities. When I imported all my attachments to the Media Library, I had the “Use permanent redirects” option checked. All my post images don’t show up because the image URL path is wrong and the domain name is repeated twice.

    Example:

    http://domain.com/http://domain.com/wp-content/uploads/year/month/image.jpg

    How do I fix this and is there any way to undo the permanent redirect? What should be the right settings when importing attachments to the Media Library?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The next release does not have use permanent redirects as the default, it should not be used unless you have a reason to do it.

    Anyway, there are no settings to really consider for media library import, the permanent redirect option just creates an .htaccess directives you should use. If the URLs to your media library attachments have been changed in your database, you can either restore a backup or use a program like: http://wordpress.org/extend/plugins/search-and-replace/

    Thread Starter Jaypee

    (@jaypster)

    Thanks for the reply. I didn’t know that it shouldn’t be used and thought it was needed because it was the default setting. Anyways, I’ll just go ahead and replace the image URL paths.

    Btw, a couple more questions if you don’t mind. If I use a plugin to restore the default image URL, do I have to edit/remove the .htaccess directives created by the media import? And if so, where can I locate it? Thanks!

    Thread Starter Jaypee

    (@jaypster)

    I’ve fixed the image URLs using a plugin called Search Regex. I’ve reinstalled W3 Total Cache and made sure that I set it up correctly this time.

    Everything worked perfectly except when I tried the self-hosted CDN. When I tried to Export Media Library to CDN, all the images get exported except for a few files which return a “Source file not found” error. So when CDN is enabled and I try to open my blog as a guest, there are some images that are missing.

    What can I do to fix this? Thanks!

    Unfortunately, I can only answer if I have access to your server as this is not a bug that I’m aware of. Submit a bug submission via the support tab of the plugin with access if you can.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: W3 Total Cache] Undo 302 Redirects’ is closed to new replies.