WordPress.org

Forums

W3 Total Cache
[resolved] unable to make cloudflare api request (CloudFlare/W3TC) (17 posts)

  1. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Just set up CloudFlare with no hassle. Then set up W3TC, which I haven't used in over a year... it's come a long way!

    ANyway, in trying to connect W3TC with CloudFlare, I keep getting the 'unable to make cloudflare API request' error message.

    Any idea which end this issue may be on: W3TC / CloudFlare / My Ignorance?

    I can provide more info as needed, I'm just not exactly sure what info is relevant. I do also have the cloudflare plugin running. The connection with cloudflare service seems to be good, although not entirely sure everything is running right. I have minification on in cloudflare, not W3TC, but I don't see any changes at all.....

    Thanks! (This is on my rvoodoo.com domain btw)

    http://wordpress.org/extend/plugins/w3-total-cache/
    http://wordpress.org/extend/plugins/cloudflare/

  2. damoncloudflare
    Member
    Posted 3 years ago #

    Hi,

    "ANyway, in trying to connect W3TC with CloudFlare, I keep getting the 'unable to make cloudflare API request' error message."

    And you have your CloudFlare API key established, etc.?

    Note: You really don't need to have CloudFlare's plugin active if you're using W3TC's.

  3. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Yup, I have my API established. In the cloudflare plugin, it took just fine.

    I disabled the cloudflare plugin to see if it made a difference. I still get the same error as above.

    If I have minify on through cloudflare for all 3 types, should I be noticing any difference in my source? Nothing looks different

  4. Mike
    Member
    Posted 3 years ago #

    I have the same message, always have. Never have been able to get this to work.

  5. damoncloudflare
    Member
    Posted 3 years ago #

    This will probably be hard to troubleshoot directly on the forums. Can you please contact us so we can have the engineer that developed the plugin check it out? We would need to know the domain(s) you're having an issue with.

    Contact CloudFlare

  6. damoncloudflare
    Member
    Posted 3 years ago #

    Here's what our engineer thinks is happening:

    The hosting providers are probably blocking php from
    being able to make outgoing api calls. This is a security setting
    sometimes turned on. A solution would be to use javascript to make the
    calls, but this would require a re-write of the cf integration for the W3TC plugin by the author.

  7. Mike
    Member
    Posted 3 years ago #

    OK, let me ask you this; outside of the ability to change a couple of CF settings, is there anything else that the CloudFlare section in W3TC actually does? I already have the CloudFlare plugin installed, so am I really missing anything by not being able to make a CF API request via the W3TC panel?

  8. opossum123
    Member
    Posted 3 years ago #

    Similar issue here. However, W3TC only provides three options for the CloudFlare Security Level setting, High, Medium, Low. CloudFlare, on the other hand, provides a fourth setting: Essentially Off.

    Only when I set it to "High" inside W3TC is it able to save the setting and can successfully make an API request. Do I set it to Medium or Low, however, it won't work and keeps displaying the red "unable to make cloudflare API request" message.

    Hosting provider is mediatemple, so they shouldn't be the issue either.

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I resolved my issue by leaving godaddy! Everything works perfectly on bluehost. So, it could most definitely be host related

  10. Mike
    Member
    Posted 3 years ago #

    Hmmm, I just switched hosts too, to a new managed VPS, but the problem remains.

  11. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    There's gotta be some sort of underlying server setting or something... wish I knew enough to figure out what's different for me that made it work

  12. thebeeobee
    Member
    Posted 3 years ago #

    I'm having this same issue. As a cloudflare noob, i think I want to go with a medium security setting and then adjust from there, but this simply isn't possible to change in the w3 setting.

    If i change it directly on the cloudflare site, does this override the w3 setting?

    Thanks.

  13. catchacold
    Member
    Posted 3 years ago #

    I am also on Godaddy linux plan - php 5 - W3 0.9.2.4 - With the CloudFlare plugin and I can only save with high security level.

    Why is this?

  14. damoncloudflare
    Member
    Posted 3 years ago #

    Hi,

    "If i change it directly on the cloudflare site, does this override the w3 setting? "

    Yes, it should.

    "With the CloudFlare plugin and I can only save with high security level."
    Not sure. Our API developer would need to look into this. Again, we think that there is some sort of limiting happening on the hosting side that is contributing to this:( If you would like to send more details, please send them here: http://support.cloudflare.com/cgi/discussion/new

    If you can't do it via the plugin, I would recommend logging into your CloudFlare account as an option.

  15. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I am also on Godaddy linux plan - php 5 - W3 0.9.2.4 - With the CloudFlare plugin and I can only save with high security level.

    Why is this?

    Because it's godaddy! Seriously though, certain things just wouldn't work for me on godaddy regarding w3tc, and also cloudflare's plugin, or cloudflare as part of w3tc. Luckily you can just set your security setting from your cloudflare panel. I don't know what it is on godaddy that interferes, but after switching it went away. SO I have to guess that hosting configuration was the issue

  16. astrasuite
    Member
    Posted 3 years ago #

    Have the same issue, W3TC only works with High setting. Anyway, if it will be overridden by Cloudflare, then great.

  17. balajie90
    Member
    Posted 2 years ago #

    My answer my be silly, But try to fill the domain name as naked domain

    for example domain : tipsinside.com
    (instead of http://www.tipsinside.com )

    reference : https://support.cloudflare.com/entries/22076127-what-fields-do-i-need-to-enter-in-w3tc-w3-total-cache-settings

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic