WordPress.org

Forums

[resolved] [Plugin: W3 Total Cache] tinyMCEcomments (13 posts)

  1. Gravitydk
    Member
    Posted 5 years ago #

    The plugin TinyMCEComments doesn't seem compatible and I can't work out why.
    http://wordpress.org/extend/plugins/tinymcecomments/

    If I'm not logged in, like any user, then the little MCE bold/italic and other buttons do not appear. When logged in as admin, it does work.

    I can simulate the effect for admin use by adding its two js files to the Minify setting.

    http://pwnwear.com/wp-includes/js/tinymce/langs/wp-langs-en.js?ver=20081129
    http://pwnwear.com/wp-includes/js/tinymce/tiny_mce.js?ver=20081129

    I have no idea how to solve this, any help would be appreciated. My users really like having an MCE editor for their comments.

  2. Frederick Townes
    Member
    Posted 5 years ago #

    These files cannot be minified (and not all can be. So please remove them from your settings. You can contact the plugin author to ask them to update their code so that it stands up to minification, but this is not a bug I can fix in the minify library used by W3TC without breaking other things that are working fine.

  3. Gravitydk
    Member
    Posted 5 years ago #

    Ahhh I see, thank you. I didn't realise it could just be flat-out incompatible with Minify.

    Is there an 'exclude this code' section somewhere I am missing, so I can prevent w3tc from trying?

  4. Frederick Townes
    Member
    Posted 5 years ago #

    Before I assume you were talking about JS minification. If you were, simply don't include the files there. If the problem persists then I have to assume you are using HTML minify, so you can try it's various settings, but in all likelihood cannot use it either.

  5. Gravitydk
    Member
    Posted 5 years ago #

    Yes, I was talking about JS. I double-checked and have not got the tinyMCEcomments being minified nor css combined; it's not there.

    Yet, when I am logged out mcecomments do not work, when I am logged in they do work. The settings "Don't cache pages for logged in users" does not change this behaviour.

    Any ideas then on how I exclude it from being effected? Seems peculiar.

  6. Frederick Townes
    Member
    Posted 5 years ago #

    Can you humor me and empty page cache and then browser cache (using ctrl + shift + del for most browsers. Also provide a specific page that shows the issue.

  7. Gravitydk
    Member
    Posted 5 years ago #

    I downloaded a new browser (Opera), cleared its cache, then went to this page:
    http://pwnwear.com/2010/02/01/sad-elitism-and-my-own-disclaimer/

    On that page, the tinymcecomments do not appear in the add comment box.

    Settings, in JS file management I have, in default group:
    wowhead/js/armory.js.php (footer not blocking)
    http://pwnwear.com/wp-content/plugins/use-google-libraries/js/jQnc.js?ver=2.9.1(header)

    No others. I have a few CSS listed in their section, but not from mcecomments.
    Then, when I log in, the mcecomments work again in Opera.

    Thanks for humouring me; I know it's not an end-of-the-world problem, but would be interesting to solve.

  8. Frederick Townes
    Member
    Posted 5 years ago #

    Disable minification of all JS files and retest.

  9. Gravitydk
    Member
    Posted 5 years ago #

    Deleted all JS files, retested: same behaviour.

    Disabled Minify altogether, retested: same behaviour.

    Disabled W3TC altogether.... still broken.

    Soooooo.... looks like something ELSE changed to break mcecomments at the same time as I installed W3TC, so I mistakenly attributed the breaking to the cache. Now I've got to isolate the problem (again).

    Sorry to have taken your time.

  10. Gravitydk
    Member
    Posted 5 years ago #

    Here's an alternative I found that WORKS.
    http://wordpress.org/extend/plugins/pretty-comments/

    You can edit which buttons it shows by editing jquery.wysiwyg.js, in there look for “TOOLBAR”

  11. Frederick Townes
    Member
    Posted 5 years ago #

    Soooooo.... looks like something ELSE changed to break mcecomments at the same time as I installed W3TC, so I mistakenly attributed the breaking to the cache. Now I've got to isolate the problem (again).

    Ok, well I'm glad you are moving forward.

  12. MasterC3501
    Member
    Posted 5 years ago #

    I ahve the same problem since i installed WP total cache. After I disable it it persists and now i cant freaking fix it! It started imediately after installing WP total cache and if i click anyhting in the tinymce the requires a pop up window like the hyper link or the paste text only window etc it just shows up white and has a yellow java error in the bottom corner... what can i do to fix this? it has to be total cache breaking it cause it didnt start till I installed it. I get a java error on my website too but doesnt seem to effect anything so i just ignored it. Only happens after installing wp total cache. please help

  13. Frederick Townes
    Member
    Posted 5 years ago #

    Can you submit a bug submission report from the support tab of the plugin?

Topic Closed

This topic has been closed to new replies.

About this Topic