W3 Total Cache
TDO Mini Forms Compatibility (6 posts)

  1. rrhode
    Posted 4 years ago #

    Hi there,

    I have tried to make W3 Total Cache work with TDO Mini Forms by blocking the form from caching but it doesn't seem to work. At least it isn't stopping the errors from happening. I think it might have something to do with minifying the JavaScript actually but I can't find a way to disable this from happening on the form page. I don't really understand why nothing I try makes the error going away except for unchecking "Deselect this option to disable all caching functionality.". Obviously this completely disables everything and not what I want.

    Perhaps it is the upload form page as that is shown in an iframe. It doesn't look right when the error occurs because there is some grey below it that isn't there when the error isn't there.

    My form page is at /add-a-template

    My form upload page in the iframe is at /wp-content/plugins/tdo-mini-forms/tdomf-upload-inline.php?tdomf_form_id=1&index=

    What do I have to do to fix these errors?

    Error: missing ] in index expression
    Source File: http://example.com/add-a-template/
    Line: 1, Column: 24
    Source Code:
    ss');  ajaxShadow1(); } function ajaxShadow1() {  var offset = jQuery('#tdomf_form1').offset();  var w = jQuery('#tdomf_form1').width();  var h = jQuery('#tdomf_form1').height();  jQuery('#shadow1').css({ width: w + 'px', height: h + 'px', position: 'abso
    Error: missing } in compound statement
    Source File: http://example.com/wp-content/plugins/tdo-mini-forms/tdomf-upload-inline.php?tdomf_form_id=1&index=
    Line: 1, Column: 78
    Source Code:
    extension and cannot be upload!" );    return false;  }    return true;}/*]]>*/

    Thanks =)


  2. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    First make sure that you aren't minifying the javascript needed for the form and let me know what happens.

  3. rrhode
    Posted 4 years ago #

    Hey Frederick,

    Thank you for your response =)

    The only way I can make the errors go away is to turn off minifying in the General Settings but then nothing anywhere gets minified does it?


  4. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    I don't know how to answer that question without seeing your settings. Please post the contents of the configuration file here or submit a bug submission form from the support tab of the plugin.

  5. rrhode
    Posted 4 years ago #


    Not sure where the bug submit thing is so here is the config file: http://pastebin.com/qmsKSj1z

    I tried numerous URI in the reject cache box for the form which is at /add-a-template but maybe this is nothing to do with minifying. Maybe theres a reject minifying box some place I don't see?

    It used to give a perfect score with YSlow and 94/100 with Page Speed when Minifying was on. With it off its not so good.

    Thanks for your help =)


  6. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    The bug submission form is in the support tab of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic