WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: W3 Total Cache] Stuck uploading in Amazon CloudFront or S3

[Resolved] [Plugin: W3 Total Cache] Stuck uploading in Amazon CloudFront or S3

  • hi there Frederick,

    I’ve been trying to set up the Amazon CloudFront service.

    All was ok until I wanted to upload the attachments.

    The process (see screenshot below) gets stuck and does not upload more than X files to the CDN.

    I followed all your steps from the FAQ and nothing.

    Screenshot: http://www.quicoto.com/upload/files/2011/01/7102526.png

    I can see some of the uploaded files from the Amazon Panel but they are not all the attachments I have.

    Im guessing two problems:

    1) The attachment count fails.
    2) Something with the files like “fotografía” with special chars.

    Thanks.

    Waiting for answer.

    Regards.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I don’t have an answer, but I see something similar under the same circumstances. In my case, the number of files “Processed” exceeds the “Total media library attachments” number, as in this screenshot: http://twitpic.com/3u0c84/full. In addition, I know there are files (from the last few postings, as near as I can tell) that are not uploaded to the CDN (even after 116% processing, as showing the screenshot). While I love the fact that it seems like W3TC is improving my efficiency by uploading content I haven’t created yet (116%!), I think there is something wrong.

    Turning on the CDN debug mode doesn’t show anything helpful in the output of HTML pages. I do have a long list of files in the “Unsuccessful file transfer queue” to the CDN with the error of “Object already exists”. If I delete all of the entries in this queue, they eventually come back.

    I’m using W3 Total Cache version 0.9.1.3 under WordPress version 3.0.4.

    Update on my problem.

    I used the action “Purge from CDN” from the Media Library one by one, on each of my 94 attachments and ir worked.

    Now they are showing in the site.

    It’s weird because no new files were uploaded just “refreshed”

    Maybe this can help you to find the bug Frederick

    Regards

    Update:

    I tried to upload the Theme files and it gets stuck.

    It won’t upload all the files just the one JS folder :S

    It’s me again..

    Is there any chance to make a “bulk Purge from CDN” from the Media Library?

    Plugin Author Frederick Townes

    @fredericktownes

    Can you submit a bug submission form from the support tab of the plugin?

    Is it necessary to upload the theme files? I don’t think it has anything to do with it.

    Thanks

    Plugin Author Frederick Townes

    @fredericktownes

    Is it necessary to upload the theme files? I don’t think it has anything to do with it.

    No, did I infer that somewhere?

    Done, it’s sent.

    Just an update: if you upload a new file from your post/page works perfect. Looks like the problem is just from the import media to the CDN.

    Thanks Frederick.

    Plugin Author Frederick Townes

    @fredericktownes

    This problem is often reporting, but the % related the number of installations is small; that means, if you have this problem please submit a bug submission form from the support tab of the plugin so I can investigate your case.

    I already submitted the bug 😉

    Regards

    Plugin Author Frederick Townes

    @fredericktownes

    FYI, will be adding an event logger to the next release so that issues with origin push CDN providers can be rectified without guess work.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] Stuck uploading in Amazon CloudFront or S3’ is closed to new replies.