WordPress.org

Forums

[Plugin: W3 Total Cache] Settings don't get saved (18 posts)

  1. chrissss
    Member
    Posted 5 years ago #

    I've got the problem, that i can't change the w3 total cache settings any more. When i got to "Page Cache Settings" and e.g. deactivate the option "Don't cache pages for logged in users" the option is activated again, when "Save changes" finished. I can't figure out the problem.

    Thanks
    Christoph

  2. chrissss
    Member
    Posted 5 years ago #

    I forgot to mention. When I click on "Save changes" the plugin says "Plugin configuration successfully updated". Usually I use 0.8.5.2, but i tried also the current developer version.

  3. Frederick Townes
    Member
    Posted 5 years ago #

    Can you submit a bug submission from the support tab of the plugin as this is not a known issue.

  4. invi2003
    Member
    Posted 5 years ago #

    I'm having the same problem as chrisss. I disabled all plug-ins and tried it again but same problem. Nothing on the error logs. I uninstalled it and then installed he development version. Same results. I'm at a lost.

    I'm using w3 total cache with xcache

    I did a bug submission and waiting.

    Thanks.

  5. Frederick Townes
    Member
    Posted 5 years ago #

    Can you submit a bug submission from the support tab of the plugin as this is not a known issue.

  6. invi2003
    Member
    Posted 5 years ago #

    frederick. I already submitted a report. Last i heard from you, you requested an admin account for the blog and server which I provided. I'll submit another one and will include a link to this topic.

    I also now noticed I can't even save the Hide this Message. I click on it and nothing happens

    I know you are busy but i really appreciate the help.

  7. Frederick Townes
    Member
    Posted 5 years ago #

    Unfortunately this issue can occur because the opcode cache itself caches the W3TC config' file. Only testing on your server will help determine if there's a workaround and frankly caching the settings file is good, but the opcode cache is supposed to check for file changes in order to avoid this issue. APC does a good job in this regard.

  8. invi2003
    Member
    Posted 5 years ago #

    I followed your suggestion and went away with Xcache. I was running into errors trying to install APC so I went ahead with eAccelerator . I can see improvement already

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

    Minified using disk
    Page Caching using disk (enhanced)
    Database Caching using disk (user is logged in)
    .

    chrissss I hope you to fix you problem too.

    fredericktownes
    What are the best settings using eAccelerator? Any suggestions?

    Thanks

  9. Frederick Townes
    Member
    Posted 5 years ago #

    What are the best settings using eAccelerator? Any suggestions?

    Circumstances vary to much to just blindly give you suggestions. Sorry.

  10. invi2003
    Member
    Posted 5 years ago #

    Thank you very much. PS i had another issue with ea not being able to select it. I was able to fix it following the suggestion here
    http://wordpress.org/support/topic/413477?replies=14#post-1589645

    THANKS AGAIN

  11. Greg Rickaby
    Member
    Posted 5 years ago #

    I have the same issue where settings wont save. It happens on sites that are just running disk cache too. I even "empty all cache" to no avail.

    Usually, I end up clicking "Save changes" until they do, 10-15 clicks later.

  12. invi2003
    Member
    Posted 5 years ago #

    gregrickaby I suggest you check the logs for any errors. /var/log/httpd/error_log < this is the location where mine is located. If you havent just submit a bug report from the w3 total cache support tab option.

  13. Frederick Townes
    Member
    Posted 5 years ago #

    @invi2003 is correct. @gregrickaby sounds like you have a network-based file server, that is the cause of that issue.

  14. Gilligan
    Member
    Posted 4 years ago #

    While you are configuring w3tc, set apc.stat = 1 in php.ini

    This is the default setting. It requires the cache to check for file changes on every request for a file, which is a performance issue that may cause you to experience decreased performance with the cache plugin enabled.

    Stat on can also cause the problem of the cache settings and alerts being cached... which is an annoyance.

    After you have tested and deployed, set apc.stat = 0 and you will see performance increase.

  15. Frederick Townes
    Member
    Posted 4 years ago #

    @PlayGod, I'm not really seeing amazing performance increases by toggling this setting.

  16. Gilligan
    Member
    Posted 4 years ago #

    FT, I think you may be ~somewhat~ correct. I changed my sites back to apc_stat=1 and there doesn't seem to be much of a performance hit. I was going by the recommendations from php.net:

    On a production server where the script files rarely change, a significant performance boost can be achieved by disabled stats.

    However, it looks like w3tc performs best with apc_stat=1. I did have trouble with plugin and core upgrades with apc_stat=1 (automated upgrades with w3tc & wordpress, and manual upgrades of other php packages such as vanilla, phpbb, joomla and slideshowpro director).

    It may be worthwhile to research apc_stat a bit more and see what can be done to allow the cache (either plugin or APC itself) to recognize when important files are changed, without the overhead of polling each script every time it is called. While the performance hit for a single server running a single script package may not be overwhelming, I'm sure it could create performance issues on a setup like mine, which has 30+ virtual servers running various PHP script packages on a single physical machine.

    I don't currently have the time to do a detailed performance comparison, but in general I see CPU load is about 2x greater under normal load when apc_stat=1 vs apc_stat=0. It's still manageable at ~1.5 but I would prefer the normal load to be less than 1... it was consistently under 1 with apc_stat=0. Remember I am running 100+ PHP script packages on a single physical server with 5 IP addresses, multiple domains, Email, PHP, CGI, Perl, MySQL and PostgreSQL. So, any single measurable performance issue has exponential consequences.

  17. Frederick Townes
    Member
    Posted 4 years ago #

    No argument there, everything has it's consequences.

  18. timbrd
    Member
    Posted 4 years ago #

    Thanks a lot, I was going crazy trying to figure out why I cannot save settings. "apc.stat=1" solved the problem.

    WordPress 3.0.4
    W3 Total Cache 0.9.1.3
    APC 3.1.7

Topic Closed

This topic has been closed to new replies.

About this Topic