W3 Total Cache
[resolved] RSS feed caching not working (5 posts)

  1. efikim
    Posted 6 years ago #

    I set the RSS feed on my blog http://words.mikefinley.co.uk to be cached by W3 total cache, as that was the recommended setting.
    I tried to submit the RSS feed on my site to bloggrader, and it complains that the feed isn't valid. I also tried with bloglines (which is the newsreader I usually use) and it doesn't see anything in the feed.
    If I disable caching of the feeds, both are happy with the feed. Its currently left that way, though I can easily switch it back to cached if you want to test - at present its unlikely anyone but me is actually using the feed.

    Using WordPress version 3.0 and W3TC version

  2. Frederick Townes
    Plugin Author

    Posted 6 years ago #

    Disable minification for feeds.

  3. efikim
    Posted 6 years ago #

    Thanks, that works.

    However, it does submit the cached feeds with a type of text/html rather than one of the valid application/xxx types, so there may be some cases where it won't work (according to the W3C feed validation service)

  4. Frederick Townes
    Plugin Author

    Posted 6 years ago #

    I'm aware of the issue. Disk enhanced doesn't allow for returning any other mime-type than text/html. For now, this is simply a limitation.

  5. s016752
    Posted 5 years ago #

    I can't figure out any thing about setting this so the RSS feed will work. Can of you tell me in laymen terms what you are talking about. lol

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic