WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » [Resolved] [Plugin: W3 Total Cache] Revision 264695 breaks .htaccess

[Resolved] [Plugin: W3 Total Cache] Revision 264695 breaks .htaccess

  • Revision 264695 breaks .htaccess in docroot resulting in a 500 error.

    (after upgrading from a previous development version)

Viewing 15 replies - 1 through 15 (of 27 total)
  • From the error_log:
    [Tue Jul 20 13:59:55 2010] [alert] [client 82.93.249.226] ***/html/.htaccess: RewriteCond: bad flag delimiters

    A complete reinstall of the plugin didn’t solve the problem. (But I did not reset all the plugin options).
    I put back the older revision…

    Plugin Author Frederick Townes

    @fredericktownes

    You have to make sure that the directives from the previous release are removed from .htaccess. Some of the directives were changed to better handle spaces in user agent strings.

    Hello, I installed version 0.8.5.2 on a development site (running WP3.0) and it nuked my existing .htaccess file. I had to rebuild it – thankfully I could remember many of the special re-write rules I had in there. Did I miss something in the install about a way to preserve your existing .htaccess file?

    Thanks!

    Plugin Author Frederick Townes

    @fredericktownes

    I don’t know what nuked means specifically. v0.8.5.2 does not officially support v3.0.

    Sorry – it wrote over the existing file so that all my re-write rules for permalinks, etc were lost. And…oops about the 3.0! Good thing I’m working in a test environment.

    Thanks for the speedy reply.

    Plugin Author Frederick Townes

    @fredericktownes

    W3TC doesn’t overwrite it appends only. If you can demonstrate a case to the contrary, let me know how to duplicate.

    Will try that. Thank you! 🙂

    New version (!) destroys also a clean .htaccess rendering my website unusable. (500 error as mentioned above) Guess i have to go back to an old development version…

    Upgraded…

    500 Error.

    Went back and cleaned up my .htaccess file to original *without any W3 Cache rules in it)…

    Deactivating & Reactiving the plugin causes a 500 error, even with a fresh new .htaccess file.

    Bad move dude, this is gonna break a lot of installs, and most won’t know what to do…

    W3TC doesn’t overwrite it appends only. If you can demonstrate a case to the contrary, let me know how to duplicate.

    I don’t know how to demonstrate other than to say that’s exactly what happened to me.

    Plugin Author Frederick Townes

    @fredericktownes

    @mirsasha – can you duplicate the issue so I can understand the case, that’s happening here?

    @anteck – I cannot duplicate the issue on a clean installation. If you’d like to help me out by writing me directly it would be appreciated.

    I managed to resolve it like this:

    • create export of settings in old version of plugin (revision 264695 development version in my case).
    • reset all setting in old plugin to default
    • disable (and remove) old plugin
    • make sure .htaccess in docroot is ‘clean’
    • install new version
    • Do all settings in new by hand, not an import (using old export file as a guide).

    I think the problem has something to do with the settings from one of the 0.9 development releases. Resetting it all to default before uninstalling seems to resolve the problem.

    @fredericktownes: try to duplicate the issue after installing 0.9 rev. 264695, and the trying to upgrade. Could be due to a specific setting though. I still have my old settings form the revision. I will e-mail these via w3 edge web site contact form.

    Thanks for the great work! 🙂 I love the plugin.

    Plugin Author Frederick Townes

    @fredericktownes

    Unfortunately, not everyone has used development versions, so this test isn’t enough. Anyway a minor release will be out shortly.

    After upgrading to newest version it broke my site – I see – 500 internal error.

    I’m don’t know any coding or somethink and contacted my host provider asking help with this – they sad .htaccess.
    is configured incorrect and they fix that with bak file or something I don’t know.

    Now all my sites is back – but w3 tatal cash does’nt work I see this:

    You’ve selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please run chmod 777 /home/neobank/public_html/sydneyphoenix.com/.htaccess, then “try again”

    To manually modify your server configuration for enhanced mode append the following code:

    # BEGIN W3TC Page Cache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_USER_AGENT} (2.0 MMP|240×320|ASUS|AU-MIC|Alcatel|Amoi|Android|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|dopod|Elaine/3.0|Ericsson|EudoraWeb|Fly|HP.iPAQ|Haier|hiptop|htc|Huawei|i-mobile|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo Wii|Nitro|Nokia|Novarra|O2|Opera Mini|Opera.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation Portable|portalmmm|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SIE|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian OS|SymbianOS|TS21i-10|Toshiba|Treo|UP.Browser|UP.Link|UTS|Vertu|WILLCOME|WinWAP|Windows CE|Windows.CE|Xda|ZTE|vodafone) [NC]
    RewriteRule .* – [E=W3TC_UA:_mobile]
    RewriteCond %{HTTP_USER_AGENT} (iPhone|iPad|iPod) [NC]
    RewriteRule .* – [E=W3TC_UA:_apple]
    RewriteCond %{HTTPS} =on
    RewriteRule .* – [E=W3TC_SSL:_ssl]
    RewriteCond %{SERVER_PORT} =443
    RewriteRule .* – [E=W3TC_SSL:_ssl]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =””
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|wp-.*\.php|index\.php) [NC,OR]
    RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
    RewriteCond %{HTTP_USER_AGENT} !(bot|ia_archive|slurp|crawl|spider) [NC]
    RewriteCond “/home/neobank/public_html/sydneyphoenix.com/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}” -f
    RewriteRule (.*) “/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}” [L]
    </IfModule>
    # END W3TC Page Cache

    and another.:

    The required directives for fancy permalinks could not be detected, please confirm they are available:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Damm I don’t know coding – one time used file zilla to instal the script…. thats all!

    Now I’m completely confused and don’t know what to do. :/

    Any help out here?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] Revision 264695 breaks .htaccess’ is closed to new replies.
Skip to toolbar