Support » Plugins and Hacks » [Plugin: W3 Total Cache] redirect error

Viewing 13 replies - 1 through 13 (of 13 total)
  • Here is the htaccess for the .com (first wordpress install)
    http://wordpress.pastebin.com/k5PGns3x

    Here is the htaccess for the .nl (second wordpress install)
    http://wordpress.pastebin.com/UmSjZrjV

    I believe I replied to your support submission, make sure your redirect rules are at the top of your .htaccess file.

    Make sure your redirect rules are at the top of your .htaccess file

    This fixed my issue. Many thanks!

    Ok cool.

    Thanks! That fixed it for me, too. Was struggling forever on this.

    Glad to hear it.

    How can we make sure the redirect rules are on the top when whenever we make a change to W3 total access it automatically put it’s rewrites on the top? is there some php code we can use to tell it to put it on the bottom?

    I have the same problem as Dan.

    Hi,

    i did exactly as You said and put usual WordPress htaccess rules at the top so my top looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    and after that is all the rest of w3 total cache plugin htaccess rules. But it doesn’t resolve my problem. Stil have problems with www to non-www redirect. My website is http://symbolika.net (instaled as http://www.symbolika.net ) and should be normalny with www but it doesn’t work properly.

    Another website is http://przyslowia-cytaty.com ( should be http://www.przyslowia-cytaty.com ).

    I checked it in Opera, FireFox, Internet Explorer nad 2 sites to redirection check and it doesn’t work :/

    What do I need to do with that? Please help.

    You need to have a redirect, first of all. With what you have there, there isn’t a redirect. Here is the generic rule you need… put this in the WordPress htaccess rule:

    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

    If you need https (I haven’t tried this one):

    RewriteCond %{HTTPS} off
      RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
      RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    
      RewriteCond %{HTTPS} on
      RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
      RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

    The problem is when you change a setting in W3TC, it diverts the WordPress rules back under the W3TC rules.

    damn, i thought that the default wordpress rule will work out but in some other configuration.

    I spent all day to change it and try try and try… and it’s all for nothing.

    Irastart You’re right! Thanks a lot for help : ) it works now.

    No problem. I use elegant themes too… their themes are great:

    The next release handles rules modifications better.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: W3 Total Cache] redirect error’ is closed to new replies.