Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Problems with dev version – cdn css background urls no minify files to up

  • Resolved shortster

    (@shortster)


    My first problem occurred when I moved my local site on localhost:8888/mywebsite to my server at http://www.mywebsite.com/tst. After moving the files and importing the database, in which I did a find and replace of the servername, I logged in to wp-admin and changed my cdn (s3) from static.dev.mywebsite.com to static.tst.mywebsite.com. After this I changed all the urls in the minify settings. I uploaded all my files to static.tst.mywebsite.com through the plugin, emptied all the caches en loaded my site in the browser. Everything was fine except my background images weren’t there. In firebug I saw that in my minified css on static.tst.mywebsite.com all my background images urls were still pointing to /mywebsite/pathtoimage/image.jpg instead of to /tst/pathtoimage/image.jpg.

    After trying a lot of things and rechecking everything twice I gave up and decided to start from scratch, which led me to my second problem.

    So now I have a clean wp 3.0 install on my server, installed all my plugins and redid all my settings. After everything was ok I installed w3 total cache (development version again). After setting the writing permissions to wp-config and .htaccess all was good. Then I entered all my js and css urls in the minify settings and checked in the browser (love the preview mode btw). Still doing great so far. Now I activated the cdn setting and entered my bucket info. Then when I want to upload the minified files it says Total files: 0. Other files upload fine. And the css/js files aren’t loaded in the browser. Strange thing is that when I try the url to a gzip minified file on the cdn I get an xml with access denied. Permissions problem somewhere?

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Frederick Townes

    (@fredericktownes)

    S3 bucket “permissions” are inadequate or you’re using a CNAME that is not authorized. Either create a new bucket using the plugin or use another tool to modify the access control list for the existing bucket.

    shortster

    (@shortster)

    Hi Frederick,

    Thanks for your quick reply! Unfortunately bucket permissions or CNAME does not seem to be the problem.

    I made a new s3 bucket from within the plugin, did the test upload and was ok. I’m not using a CNAME (still have to find out how CNAMEs work).
    All files are uploading ok, but when I select ‘Upload minify files’ the popup still says 0 files to upload..

    With cdn disabled the minified files work perfectly.

    shortster

    (@shortster)

    I’ve even tried setting the bucket permissions list and update/delete to ‘everyone’ in the AWS management console for s3. But no luck.

    blau

    (@blau)

    I don’t use S3 directly but Cloudfront with success:

    I added up to 10 CNAME to cloudfront (media1.mysite.tld media2 media3…), added the 10 CNAMEs in my site DNS so that I have somethinh like

    media1.mysite.tld CNAME mycloudfronturl.cloudfront.net
    etcetera

    Plugin Author Frederick Townes

    (@fredericktownes)

    Can you submit a bug submission report from the support tab of the plugin?

    shortster

    (@shortster)

    I did a bug submission, thanks for your work and support.

    Plugin Author Frederick Townes

    (@fredericktownes)

    I don’t know your real name @shortster. Did I resolve your issue?

    shortster

    (@shortster)

    Yes you fixed it! For anyone else with the same problem. It was a permissions issue on the w3tc/min folder on the server.

    shortster

    (@shortster)

    O btw, my name is Sjoerd

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok great.

    firstly sorry my english. i hope understand me.

    i am using w3 total cache and aws for cdn. its working good. but i have a little problem for background urls. <div class=”slide-box” style=”background:url(<?php wp_get_attachment_url( get_post_thumbnail_id( $post->ID ) ); ?>) no-repeat;”>

    <div class=”slide-box” style=”background:url(http://www.212medya.com/wp-content/uploads/2011/04/yeni-nesil-web-tasarim.jpg) no-repeat;”>

    i want to change like this<div class=”slide-box” style=”background:url(http://cdn.212medya.com/wp-content/uploads/2011/04/yeni-nesil-web-tasarim.jpg) no-repeat;”>

    background url dosnt rewrite to cdn. how can i fix it

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: W3 Total Cache] Problems with dev version – cdn css background urls no minify files to up’ is closed to new replies.