Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Plugin triggers a fatal error

  • I have a brand new installation of Worpdress MU 2.9.2
    A fresh install of W3 Total Cache 0.9.0
    I’m hosted on MediaTemple Grid Service.

    I click “Activate” and get the following message:

    Plugin could not be activated because it triggered a fatal error.
    /[path]/domains/[mydomain].com/html/wp-content/db.php  could not be created, please run the following command:
    chmod 777 /[path]/domains/[mydomain].com/html/wp-content
    then re-active plugin.

    But I have already run a CHMOD on the wp-content directory to 777!

    Virtually the same thing is occuring on a separate installation of WordPress MU 2.9.2. On this one I upgraded your plugin instead of it being a fresh install. It says:

    Plugin could not be activated because it triggered a fatal error.
    /[path]/domains/[mydomain].com/html/wp-content/w3tc-[mydomain].com/min/index.php  could not be created, please run following command:
    chmod 777 /[path]/domains/[mydomain].com/html/wp-content/w3tc-[mydomain].com/min

    But once again, I have already fun a CHMOD on this directory to 777.

Viewing 15 replies - 16 through 30 (of 36 total)
  • I am having the same issue when activating the plug-in – Internal Server Error – the wp_content directory is present:

    /public_html/wordpress/wp-content/plugins/w3-total-cache/wp-content

    When setting the 777 is just on one folder or is it recursive?

    I noticed that my Internal Error is caused but the entries added to the .htaccess file:

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_setenvif.c>
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    </IfModule>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css application/x-javascript text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon
    </IfModule>
    <FilesMatch “\.(?i:css|js)$”>
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By “W3 Total Cache/0.9.1.1”
    </IfModule>
    </FilesMatch>
    <FilesMatch “\.(?i:html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml)$”>
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By “W3 Total Cache/0.9.1.1”
    </IfModule>
    </FilesMatch>
    <FilesMatch “\.(?i:asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|swf|tar|tif|tiff|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$”>
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By “W3 Total Cache/0.9.1.1”
    </IfModule>
    </FilesMatch>
    # END W3TC Browser Cache

    I removed all the entries and the err

    or stops.

    Any ideas if this is related somehow:

    I updated my host and DNS to GoDaddy – at the moment the site is flying without any cache manager – we’ll see how things go. – The shared host I was one was ipowerweb. I would not recommend

    Plugin Author Frederick Townes

    (@fredericktownes)

    It would be helpful to have the error message from your error log.

    I too am having this problem. I was fiddling around with the settings, uninstalled w3 cache, reinstalled and got the “internal server error.”

    After some examination, I found that the “FilesMatch” directive in .htaccess was causing the issue when “Browser Caching” was turned on.

    Turning browser caching off for the moment. It would be nice to know the reason for the error…

    Plugin Author Frederick Townes

    (@fredericktownes)

    Directive incompatibility with Apache 1.3.

    Hmm – but it was working last night! Now I get the error if I turn on Page Caching as well.

    But you’re right. I just checked and I have Apache Apache/1.3.33.

    According to the documentation though, FilesMach is compatible with Apache 1.3 and above: http://httpd.apache.org/docs/1.3/mod/core.html#filesmatch

    I’m running WP 2.8.6 on Apache 2.0.63 and today, when I updated w3tc to its latest version, I got a fatal error when the auto-update mode tried reactivating it. Immediately afterwards, the dedicated server become irresponsive and slow (maybe because I’m getting good traffic but the plugin is inactive). However, every time I try to activate the plugin, the server goes berserk.

    Any ideas?

    After a while, the server has stabilized and I was able to reactivate after some 777 chmodding.

    Plugin Author Frederick Townes

    (@fredericktownes)

    Errors in your error log? Is the uploads path in your miscellaneous options actually correct?

    In order to access the error logs (not available in shared hosting.), I just upgraded my Godaddy hosting plan to Delux. The change is still “pending.”

    I’ll look at the error logs and tell you what I see.

    By uploads folder, you mean Settings->Media->”Store uploads in this folder “? It’s the default wp-content/uploads. Just to make sure, I changed the name, saved, and changed it back.

    My blog is in a subdirectory with it’s own .htacess. I still get “Internal Server Error” when “Browsing Cache” and “Page Cache” modify the root .htaccess file…

    Thanks for all the support Frederick

    Here is the error I’m getting:

    “Regex could not be compiled”

    Does that mean anything?

    Plugin Author Frederick Townes

    (@fredericktownes)

    It means you’re using Apache 1.3 and some recent changes are incompatible with it. You can try the development version which fixes the issue.

    Thanks Frederick. I migrated to Bluehost and everything is working fine now! They’re using Apache 2.x…

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok great.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[Plugin: W3 Total Cache] Plugin triggers a fatal error’ is closed to new replies.