Support » Plugins » [Plugin: W3 Total Cache] Plugin reports memcached is not working…

  • I recently installed memcached on my VPS and confirmed that it’s working:

    memcache support enabled
    Active persistent connections 0
    Version 2.2.5
    Revision $Revision: 1.111 $

    Directive Local Value Master Value
    memcache.allow_failover 1 1
    memcache.chunk_size 8192 8192
    memcache.default_port 11211 11211
    memcache.default_timeout_ms 1000 1000
    memcache.hash_function crc32 crc32
    memcache.hash_strategy standard standard
    memcache.max_failover_attempts 20 20

    After installing the 0.8 version of the plugin, I see this at the top of the setup page:

    Database caching is not available. Memcached server localhost:11211 is not running or is non-responsive.

    What can I do to correct this?
    Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Do you have memcached installed and running as daemon on port 11211 listening on localhost? it appears you have successful installed the PECL Memcache PHP extension which is great, but only 50% of the installation (and not the required bit).

    Please check out the instructions in the plugin to make sure that everything is all set for memcached daemon.

    frederick,

    First of all I thank you for the excellent plugin! I can’t wait to unleash the full potential.

    I ran a module installer in WHM/cPanel before I found your instructions. It looks like I may be using a different flavor or memcached??? My version is 2.2.5.

    The install was automated so now I’m trying to figure out how to run memcached. I recycled Apache assuming memcached would start with it but I still get the error message.

    Any suggestions?

    I found the command I need to run:

    memcached -d -m 1024 -u root -l 127.0.0.1 -p 11211

    Now I just need to find out where it was installed so I can run it!

    Woohoo! I got it working! All I had to do was follow the instructions under “Memcached (daemon) Install”.

    The only step I could not complete was #7 to make sure memcached starts with server reboot. When I execute this:

    # touch /etc/rc.d/init.d/memcached

    I got an error – something about file not found. The path does exist but for some reason it won’t create the file?? Ideas?

    Oh, I’m also making use of the memcache.php app you include with the plugin. That’s how I confirmed it’s working

    :o)

    Make sure that you # chmod +x /etc/rc.d/init.d/memcached as it says in the instructions, then # /etc/rc.d/init.d/memcached will work.

    OK I got the memcached file set up. What if I need to change the amount of memory I want to use (i.e. -m 256 instead of 128) ?

    I guess I need to know how to stop memcached first right?

    You can stop memcached like any other process with a kill command if you know the process ID. As for the memory, 256 – 348 is often “enough.”

    Cool thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: W3 Total Cache] Plugin reports memcached is not working…’ is closed to new replies.