WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] Plugin could not be activated because it triggered a fatal error.

[Plugin: W3 Total Cache] Plugin could not be activated because it triggered a fatal error.

  • When I try to activate this plugin on a my wpmu 2.9.2 server, I get this error:

    Plugin could not be activated because it triggered a fatal error.

    I can’t find any errors in my error.log nor can I find out why it’s failing. I can see it generating the config file in my wp-content directory but it still fails. Any ideas what could be causing this or where I can diagnose the errors? I’ve tried disabling all other plugins to see if anything was conflicting but have found nothing. Any thoughts?

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am having the same problem.
    I did chmod 777 wp-content and my PHP is not in safe mode.

    below the error message there is an empty iframe:
    <iframe style="border:0" width="100%" height="70px" src="http://myserver.net/blog/wp-admin/plugins.php?action=error_scrape&plugin=w3-total-cache/w3-total-cache.php&_wpnonce=12c5e2f234"></iframe>

    Another possibly relevant datapoint is that I use a localized version of WordPress (Hebrew).

    This is not a common issue, if you can submit bug submissions via the support tab of the plugin with access to your sites that would be ideal.

    Since I cant activate the plugin at all, I can’t submit a bug report via the support tab of the plugin. I don’t see any errors in my logs about the errors. Is there any other way to diagnose?

    same problem here, cannot activate due to fatal error, which means no support tab to click on to send error reports.

    Using wpmu 2.9.2

    Can you try to increase the PHP memory limit?

    I already have the memory limit at 256MB, how high do I need to go?

    The server is dedicated, so if it helps I can provide access for troubleshooting if you think it would help.

    I have heard great things about your plugin, and would love the opportunity to try it out if possible.

    Same here. Please post here if you find a solution.

    Just for kicks I upped the php to 4GB and still same error, so I don’t think it’s a memory issue. I only have 16GB available, and really need to reserve a good portion for other services.

    If you’re sure you have the right permissions on the wp-content/ and wp-content/upload/ directories, the only way to trouble shoot this is with server access as I cannot duplicate this issue. You can contact me through my web site.

    Another datapoint: I have PHP version 5.1.6. Could that be the problem?

    @frederick
    I sent you the server information on Friday. If you did not receive it, let me know and I’ll gladly send it again.

    thanks

    I don’t think I have it.

    wp-content/upload/ directory ? Ummm, where does it say to create this. Did anyway, CHMODed to 777, and it doesn’t clear the error.
    WPMu 2.9.2, Apache 2, PHP 5.2.11

    This bug is fixed in the next release.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: W3 Total Cache] Plugin could not be activated because it triggered a fatal error.’ is closed to new replies.
Skip to toolbar