Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Pages turn to binary gibberish causing save dialogue to appear

  • Resolved Graham Stoney

    (@greyham)


    I’m having a transient problem hit my sites using W3 Total Cache, where accessing certain posts causes a binary download which triggers Firefox’s Save dialogue to appear. It always goes away when I clear the W3TC disk cache, and I have people reporting it to me on pages which look fine when I view them, so it seems to be transient. I can’t cite an example right now, but I’ve seen this often enough that I wanted to report it. Has anyone else noticed this?

    Thanks,
    Graham

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 12 replies - 1 through 12 (of 12 total)
  • If you haven’t already can you submit a bug submission form from the support tab of the plugin because we are unable to duplicate?

    Thanks for your reply Andreas. I submitted a bug report using the support tab of the plugin a few weeks ago. The problem occurs because the .htaccess file in the cache directory disappears somehow. I suspect something is going wrong in the cache flush logic, although Frederick replied to me by email saying that wasn’t possible. I can’t see how else the .htaccess file could get deleted.

    I’m not sure the id of the bug report as Frederick was corresponding with me based on a second report I submitted: [W3TC Submit a Bug Report] #201112280055: WordPress Firewall 2 blocks W3 Total Cache Bug Report Submission

    My work-around is to turn off gzip compression. I’m not certain whether this stops the .htaccess file from disappearing, but it means the site still loads even without it.

    Cheers,
    Graham

    Plugin Author Frederick Townes

    (@fredericktownes)

    It would appear that your server is already doing some compression and the page compression should be disabled on the browser cache settings tab.

    Hmmm… I’ve no idea what would cause it to do that, and the .htaccess file disappearing remains a mystery to me. But oh well, at least I have a workaround for the problem.

    Thanks,
    Graham

    Yup, I had the same thing going on — and I disabled the compression like Frederick said and then it worked fine. I do have gZip enabled on my server. Thanks Frederick.

    Thanks Curtis; where exactly do you have gzip enabled on your server then if it’s not in the W3 Total Cache settings? Is there a CPanel setting for this or something?

    Cheers,
    Graham

    Yes, I think I saw it in the PHP configurations somewhere in WHM. I’m not totally sure. But one thing’s for sure, when I disabled compression in W3TC, that frightening issue — where hapless website visitors would be asked if they want to download a file — went away.

    Plugin Author Frederick Townes

    (@fredericktownes)

    You’re in the best shape (in terms of server performance), if you let W3TC handle compression (by disabling it in WHM).

    I’m really hoping we can get this problem of the .htaccess file in the cache directory disappearing resolved so we can do exactly that Frederick. Until then, having my site break every few weeks makes W3TC compression too unreliable for me. Thanks so much for looking into this for us.

    Cheers,
    Graham

    Plugin Author Frederick Townes

    (@fredericktownes)

    A bug submission form is probably the best way to go at this point, so i have more details to work with.

    Thanks for your reply Frederick. I submitted a report about this several weeks ago via the W3 Total Cache bug submission form.

    Frederick just wanted to get back to you and say how right you were about better performance with W3TC handling compression.

    I discovered that I could leave compression enabled on my server for my other sites that need it (e.g. Magento…) and disable it for my sites running W3TC. Then I enabled it on W3TC and saw a huge improvement in response and page load times.

    Thanks again and again.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: W3 Total Cache] Pages turn to binary gibberish causing save dialogue to appear’ is closed to new replies.