Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Page Cache URL rewriting is not working

  • Hi I have nginx as my webserver and when I enable page cache using disk:enhanced I get this error:
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Anyone know how to fix this?

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am having the same issue, i found out it tries to get the url http://www.example.com/w3tc_rewrite_test and if it cannot find it it shows the error.

    Manually i can load it and it is OK but somehow i keep getting this error message while URL rewriting is Enabled including all other modules.

    After some debugging i found out my Maintenance Mode plugin was causing the enhanced pagecaching to fail while having it in maintenance mode.

    The reason for this w3tc does a server side page request ( not logged in ) to the http://www.example.com/w3tc_rewrite_test address, when not logged in on my page they get redirected to a maintenance page so the response will never be the exspected OK and fails.

    Hope this helps for anyone with a maintenance plugin installed 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: W3 Total Cache] Page Cache URL rewriting is not working’ is closed to new replies.