W3 Total Cache
[resolved] Page Cache not working and error_log going to epic sizes... (4 posts)

  1. Julian Fernandes
    Posted 4 years ago #

    Hello again,
    So, lately W3 Total Cache started to say this: It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    The .htaccess directives are where they was supposed to be and are what they was supposed to be (according to install tab). So, after this erro started to happen, i noticed this on my error_log:

    [12-Jan-2012 19:21:55] PHP Fatal error: Call to undefined function w3_url_format() in /xxxx/xxxx/xxxxx/wp-content/plugins/w3-total-cache/lib/W3/Plugin/PgCacheAdmin.php on line 213

    Over and over again... to a point where i need to delete the error_log lots of times, cause the size starts to bother me.

    If i disable Disk (Enhanced) and choose Disk it works again. Is there any fix for that? I reported it was a bug, but never got any reply.

    I'm running LiteSpeed, CloudLinux and CloudFlare. On a side note, i also have eAccelerator activated on the server, but W3 Total Cache can't see it?


  2. jlomaga
    Posted 4 years ago #

    I will second this post. I just happened to notice the large size of my error log and I also see this error pop up MANY time every day. I'm also running Litespeed however using memcache.

    hitoriix I don't think this is a server issue, more then likely a line of bad php code.

  3. Julian Fernandes
    Posted 4 years ago #

    Any word from the dev?

  4. andreasnrb
    Posted 4 years ago #

    Try the development version w3_url_format is fixed there. http://wordpress.org/extend/plugins/w3-total-cache/download/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic