Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Page and Browser Caching not working

  • Resolved Frans Otter


    Hi, can anyone help me out?

    Yslow is giving me a Grade F on Compress components with gzip. I use the inFocus theme of mysitemyway and WordPress 3.4 on a Bluehost Apache server (shared).

    I checked the compatibility of the server with W3 Total cache plugin and it says that mod_deflate, mod_rewrite, etc. is not detected which is required for Page and Browser Caching.

    This is the comment of Bluehost Support Theme:
    Mod_rewrite is already enabled for all accounts on the server, so if that plugin is still not working I would recommend contacting the plugin developer.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I host a few sites on Bluehost and mod_rewrite is enabled, as well as mod_deflate.
    However their support says that compression will only run using mod_deflate as resources allow, that their is no end-user control. I use Bluehost for my WP sites, and I haven’t seen any issues with caching.

    Thanks for the response!

    Maybe I had to be more explicit on this topic. You’re absolute right about mod_deflate. I dived more into the details of this matter and found that the problem lies in minifying JavaScript. Apparently the inFocus theme of mysitemyway(.com) doesn’t allow .js to be minified. CSS is not a problem do.

    I already addressed this issue to them. I sincerely hope it’s possible for the mysitemyway guys to allow W3 Total Cache to minify JavaScript in the near future since their themes are very flexible. Not only does it improve loading time but Google Page Speed and Yslow will give themes like infocus lower rates for this.

    Awesome! I’m sure they can figure something out. Good luck!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: W3 Total Cache] Page and Browser Caching not working’ is closed to new replies.