Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Not caching

  • Resolved Joseph


    I’ve just switched from WP-Super Cache to W3 Total cache but I can’t get caching to work. My pgcache folder is alway empty except for a .htaccess file (tried cmod 777 as well). Tried debug mode but doesn’t work either as no comments are added at the end. Also tried deactivating other plugins but the result is the same.

    I have disk enhanced mode for page cache and disk mode for minify enabled with the rest disabled. I’ve also unchecked no caching for users.

    Compatibility Test:
    PHP Version: 5.2.14
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: On: /home:/tmp:/usr/bin:/usr/local:/etc/buagent:/var/db/buagent/:/var/softaculous/
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected

    wp-content: Write-able
    .htaccess Write-able
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Frederick Townes


    There’s another plugin interfering with W3TC’s call backs, can you disable the other plugins and check again? If that’s not the case then there’s interference from the active theme itself.

    Thanks for the reply Frederick.

    It appears to be a theme issue as both caching and debug mode worked when I switch back to the default TwentyTen theme. However, I still couldn’t get it to work with my theme even after disabling all plugins, custom functions as well as removing functions.php. All that’s left are wordpress template tags, and I do have wp_head and wp_footer in the correct place. What am I missing?

    Never mind. Problem solved. It was a silly mistake.

    I accidentally removed <html> from my header a while back when I was modifying my theme and hasn’t notice because HTML 5 validator didn’t pick it up.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: W3 Total Cache] Not caching’ is closed to new replies.