WordPress.org

Forums

W3 Total Cache
No minified files listed for transfer to CDN (9 posts)

  1. ejeliot
    Member
    Posted 3 years ago #

    I've run into a problem where no minified files (CSS and JS) are listed for upload to my CDN when clicking "Upload minify files" within the CDN section of W3 Total Cache. The option is enabled however.

    Consequently when I configure W3 Total Cache to serve CSS and JS from my CDN my site is unstyled (404 errors on those resources).

    Images and all other types of resources are identified correctly and can be copied to the CDN. Those resources are also correctly served off the CDN.

    CSS and JS files are being correctly concatenated and served locally. I'm using manual minification and specifying the full list of files to minify.

    I'm using memcached for caching (running multiple web servers), using version 3.2.1 of WordPress and version 0.9.2.4 of W3 Total Cache. My CDN is rackspace cloud files.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. andreasnrb
    Member
    Posted 3 years ago #

    If you haven't already can you submit a bug submission form from the support tab of the plugin because we are unable to duplicate and need to learn more?

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The path forward for using minify is to use manual mode and build the settings file one by one for now until it's the bugs are removed for auto mode.

  4. ejeliot
    Member
    Posted 3 years ago #

    Hi Frederick,

    Thanks for the reply. I am already using manual mode and specifying all included files manually - this doesn't make any difference. The problem still exists. What other information can I provide to help diagnose the problem?

    Ed

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry to hear that, can you submit a bug submission form from the support tab of the plugin linking to this topic please?

  6. thelaw
    Member
    Posted 2 years ago #

    Just submitted a bug report. Same problem and I've read about it ongoing for over a year. I even turned off "minify" and I'm referencing a file that doesn't exist. When I turn it on the file loads in over 3 seconds and it contains this:

    p{margin:5px 0px 5px 0px}

    This is using a CDN which may be part of the problem. But the big bug is even turning off minification is still putting out a file that it shouldn't put out because, by definition, minification is off.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry everyone, I don't believe any of these issues exist in the next release coming soon.

  8. plumwd
    Member
    Posted 2 years ago #

    That is great to hear! Looking forward to it, can't currently use the option to host the minified files.

  9. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry to hear that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic