Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] nginx.conf by W3TC only shows Browser Cache settings & omits all others

  • The nginx.conf file automagically created by W3TC (default location, root web directory) only contains the W3TC Browser Cache settings, and omits Page Cache cache, Page Cache core.

    On the w3tc_install page it shows all the proper Cacheing settings (and their appropriate nginx.conf directives) — yet when W3TC creates the nginx.conf file it does not reflect the additional directives beyond Browser Cache.

    My workaround has been to copy the directives listed in the W3TC Install tab to my /sites-available/sitename nginx conf file, but id prefer to use the method described in the inital setup to allow for changes to W3TC via the WP Dashboard.

    Ive deleted nginx.conf file generated by W3TC, and confirmed permissions and timestamp — W3TC has access to read/write that file, and recreates it after deletion, but as mentioned above its omitting all settings beyond Browser Cache.

    My setup: EC2 | Ubuntu 12.04 | nginx 1.1.19 | WordPress 3.3.2 | W3TC

Viewing 11 replies - 1 through 11 (of 11 total)
  • This is a shot in the dark, but it is a mistake others and myself have made. Did you click the deploy button? The changes won’t be applied unless you do.

    Chris Olbekson


    Level 12 Bug Squasher & Forum Moderator

    It works for me fine on Nginx. I include my w3-total.conf file from my server file so W3 Total can have the whole file to write to and I don’t have to worry about any other settings accidentally getting messed up. You should also move it out of the root directory and put it in /etc/nginx then chown it to www-data and remember to restart the server after the file gets updated.

    @haddow777 – Yes, it has been deployed and is functional when I copy & paste the rewrite rules listed on the w3tc_install page to my nginx.conf file.

    @chris – Ive tried setting the w3tc ‘Nginx server configuration file path’, with the proper permissions, and w3tc only writes the Browser Cache settings as mentioned above.

    The only way to get all the w3tc settings (Browser Cache, Page Cache, Page Cache core) into nginx is via a manual copy from the install page.

    Appears to be a bug in nginx?

    Christ. I noticed u responded to a similar problem as mine
    My “” blog had a user ID, ” diakiws”. For some inexplicable reason my co poster changed id to ” jdiakiwsblog “. And now we can’t get in to diakiws.wordpress at all except to view it. But cannot post. The new user id opens a new blog with no posts.
    Have asked for staff help. But nobody answeres. Any ideas Where or how I can get back into my blog to edit and add?

    @jdiakiw – Your issue doesnt appear to have anything to do with this thread regarding NGINX & W3TC

    I can’t say for sure what your problem is. My experience has always been that everything has been written to the nginx.conf file in the root web directory.

    I am using Debian 6, Nginx 1.2.0, WP 3.3.2, W3TC among other things.

    Are you using rewrites? It seems that when you copy from the install tab, that everything is working, caching wise. Is that the case?

    I don’t see how W3TC not writing things into the nginx.conf file would be a bug in Nginx.

    Sorry I can’t be more help.

    @haddow777 – edit: i meant to write ‘bug in w3tc’ as this issue has nothing to do with nginx as you mentioned.

    Yes, everything works fine when I copy all the rules from the w3tc install page into my site-specific nginx.conf file (in sites-available).

    Plugin Author Frederick Townes


    Which cache engine are you using? Disc Basic for example does not write to nginx since it does not use it. Disc enhanced is the only one that uses it. The Install tab displays rules even for engines that does not require it.

    If you still have issues could you send a bug report from the support tab?

    Came across while I was looking for something else. However, it seems I am experiencing the same issue – only the browser cache portion is found in the nginx.conf in the root directory.

    Also found this and gave it a try. I think this was Chris’ suggestion. Same result. My /etc/nginx/w3-total.conf only had the browser cache and didn’t reflect what was on the install page.

    I am having good luck using Virtualmin’s NginX support for WordPress with W3 Total Cache on Nginx with APC. Check my site for information about how to configure NginX support for a WordPress site. Here is a working example:

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: W3 Total Cache] nginx.conf by W3TC only shows Browser Cache settings & omits all others’ is closed to new replies.