W3 Total Cache
nginx.conf by W3TC only shows Browser Cache settings & omits all others (12 posts)

  1. kylekrall
    Posted 4 years ago #

    The nginx.conf file automagically created by W3TC (default location, root web directory) only contains the W3TC Browser Cache settings, and omits Page Cache cache, Page Cache core.

    On the w3tc_install page it shows all the proper Cacheing settings (and their appropriate nginx.conf directives) -- yet when W3TC creates the nginx.conf file it does not reflect the additional directives beyond Browser Cache.

    My workaround has been to copy the directives listed in the W3TC Install tab to my /sites-available/sitename nginx conf file, but id prefer to use the method described in the inital setup to allow for changes to W3TC via the WP Dashboard.

    Ive deleted nginx.conf file generated by W3TC, and confirmed permissions and timestamp -- W3TC has access to read/write that file, and recreates it after deletion, but as mentioned above its omitting all settings beyond Browser Cache.

    My setup: EC2 | Ubuntu 12.04 | nginx 1.1.19 | WordPress 3.3.2 | W3TC


  2. haddow777
    Posted 4 years ago #

    This is a shot in the dark, but it is a mistake others and myself have made. Did you click the deploy button? The changes won't be applied unless you do.

  3. It works for me fine on Nginx. I include my w3-total.conf file from my server file so W3 Total can have the whole file to write to and I don't have to worry about any other settings accidentally getting messed up. You should also move it out of the root directory and put it in /etc/nginx then chown it to www-data and remember to restart the server after the file gets updated.

  4. kylekrall
    Posted 4 years ago #

    @haddow777 - Yes, it has been deployed and is functional when I copy & paste the rewrite rules listed on the w3tc_install page to my nginx.conf file.

    @Chris - Ive tried setting the w3tc 'Nginx server configuration file path', with the proper permissions, and w3tc only writes the Browser Cache settings as mentioned above.

    The only way to get all the w3tc settings (Browser Cache, Page Cache, Page Cache core) into nginx is via a manual copy from the install page.

    Appears to be a bug in nginx?

  5. JDiakiw
    Posted 4 years ago #

    Christ. I noticed u responded to a similar problem as mine
    My "diakiws.wordpress.com" blog had a user ID, " diakiws". For some inexplicable reason my co poster changed id to " jdiakiwsblog ". And now we can't get in to diakiws.wordpress at all except to view it. But cannot post. The new user id opens a new blog with no posts.
    Have asked for staff help. But nobody answeres. Any ideas Where or how I can get back into my blog to edit and add?

  6. kylekrall
    Posted 4 years ago #

    @JDiakiw - Your issue doesnt appear to have anything to do with this thread regarding NGINX & W3TC

  7. haddow777
    Posted 4 years ago #

    I can't say for sure what your problem is. My experience has always been that everything has been written to the nginx.conf file in the root web directory.

    I am using Debian 6, Nginx 1.2.0, WP 3.3.2, W3TC among other things.

    Are you using rewrites? It seems that when you copy from the install tab, that everything is working, caching wise. Is that the case?

    I don't see how W3TC not writing things into the nginx.conf file would be a bug in Nginx.

    Sorry I can't be more help.

  8. kylekrall
    Posted 4 years ago #

    @haddow777 - edit: i meant to write 'bug in w3tc' as this issue has nothing to do with nginx as you mentioned.

    Yes, everything works fine when I copy all the rules from the w3tc install page into my site-specific nginx.conf file (in sites-available).

  9. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    Which cache engine are you using? Disc Basic for example does not write to nginx since it does not use it. Disc enhanced is the only one that uses it. The Install tab displays rules even for engines that does not require it.

    If you still have issues could you send a bug report from the support tab?

  10. dma999999
    Posted 4 years ago #

    Came across while I was looking for something else. However, it seems I am experiencing the same issue - only the browser cache portion is found in the nginx.conf in the root directory.

  11. dma999999
    Posted 4 years ago #

    Also found this http://wordpress.stackexchange.com/questions/54139/w3total-cache-problem-with-nginx and gave it a try. I think this was Chris' suggestion. Same result. My /etc/nginx/w3-total.conf only had the browser cache and didn't reflect what was on the install page.

  12. Gilligan
    Posted 4 years ago #

    I am having good luck using Virtualmin's NginX support for WordPress with W3 Total Cache on Nginx with APC. Check my site for information about how to configure NginX support for a WordPress site. Here is a working example: nginx.chrisgilligan.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic