Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] New version, something better, but minify STILL DOES NOT work for me!

  • Hi,
    I sent a bug report about this yet, for a previous version…
    Now, luckily, works page caching with disk optimized, previously only with disk.

    But minyfy doesn’t work at all.

    No problems for html minifying, but for css and js give always an error 400; simply, the plugin does not create the requested files, for example firebug says:
    "NetworkError: 404 Not Found - http://spingitoridicavalieri.webatu.com/wp-content/w3tc/min/3f5a17/default.include-nb.233486005.js "
    and, yes, the folder w3tc/min just contains some “.id” files, like default.include-nb.js.id , inside a folder called 3f5a17 (for my theme, I argue)

    The folder is of course writable (w3tc always creates .id files), and I surely disabled other plugins I’m forced to use for optimization (autoptimize, head cleaner, and still the do not fully work…)

    Debug:

    <!-- W3 Total Cache: Minify debug info:
    Engine:             disk
    Theme:              3f5a17
    Template:           index
    JavaScript info:
       Location     |    Last modified    |         Size | Path
     include-body   | 2010-05-20 14:18:30 |          193 | /home/MYUSERNAME/public_html/wp-content/qtip_js/qtip.js
      include-nb    | 2010-05-13 23:35:41 |        14083 | /home/MYUSERNAME/public_html/wp-content/plugins/google-ajax-translation/jquery.translate-1.4.1.min.js
    -->

    Well, now, thits is my compatibility:

    Server Modules & Resources:
    PHP Version: 5.2.10
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: On: /home/:/usr/lib/php:/tmp
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected
    WordPress Resources
    /home/MYUSERNAME/public_html/wp-content: Not write-able
    Not write-able
    
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

    And, ops, my site is http://spingitoridicavalieri.webatu.com .

    Well, I love this plugin, my site is an amatorial one, but the same I really really hope to resolve this issue, just for sake of knowledge 😀

    Thanks, bye

Viewing 15 replies - 16 through 30 (of 32 total)
  • Plugin Author Frederick Townes

    (@fredericktownes)

    I need bug submission forms from you to take any next steps.

    I need bug submission forms from you to take any next steps.

    Where? How? Here? Or are you answering to Theorib? Sorry and thank you

    Ok, I’ll send one ASAP.
    My previous one you didn’t recieved was about an old version and could not be sent successfully due to a mail sending trouble on the server I’m hosted on.
    Thanks and bye!

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok, then you can send an email.

    Frederick, is this related to the problem I reported where I cannot enable minify for CSS, though minify for other things does work?

    (you’ll recall you were working on this before your vacation)

    If so – I sent a bug report and gave you access. You still have that access! You can debug on my system.

    Nothing new on the issue ?

    Plugin Author Frederick Townes

    (@fredericktownes)

    Frederick, is this related to the problem I reported where I cannot enable minify for CSS, though minify for other things does work?

    A minify bug with http and https minify was found and is being resolved. Other than that, no @azrael-sub7 nothing new here.

    @frederick Townes
    I tested the new version on a server that has open_basedir enabled and now everything works well . Minify has no problem now , but i found a small bug on the server i tested .
    Is not affecting the plugin but it is a little annoying , after i deploy i get “Preview settings successfully deployed.” but also get “Preview mode is active: Changed settings will not take effect until you or preview mode. any changed settings (without deploying), or make additional changes. ” , although the plugin works perfectly it somehow shows in settings that is not deployed . Have you any clue why this might happen ?
    And if is not to much to ask you said before that in a new version you will enable partial caching ( meaning some parts of a page can remain dynamic ) , can i ask if you plan this feature in future versions ?

    Plugin Author Frederick Townes

    (@fredericktownes)

    Try the development version to see if that still happens. Fragment caching is already available, check the usage section of the FAQ for details.

    Thanks a lot for support i didn’t read the new FAQ sorry about that .
    The problem was that the w3-total-cache-config-preview.php could not be deleted when unlink , a permission problem from server .
    Anyway anybody who uses 000webost must know that the timezone is not set , but it can be set from .htaccess with the directive ” php_value date.timezone Europe/Bucharest ” ( change Bucharest with other available location check php manual ) .
    Thanks once again now is everything ok .

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok great.

    Azrael, great tip for timezone, thanks!
    What about open_basedir on 000webhost?

    @fredrick: i still didn’t send you the bug report 😀

    Plugin Author Frederick Townes

    (@fredericktownes)

    @the_loop, so the issue is resolved? open_basedir restrictions shouldn’t be related.

    Today on 7 september i updated the plugin to version 0.9.1.2 . But again after updated i encountered this warning message :

    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/****/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 749

    ( and same error on line 715 )
    And i made a clear update , meaning that i deleted all old files and still the same warning that causes minify not to work , so i was forced to downgrade to 0.9.1.1 that works with open_basedir set , including on 000webhost hosts that i have tested . So the past bug has return in 0.9.1.2 . Please fix if possible .

    Plugin Author Frederick Townes

    (@fredericktownes)

    I’m confident that you may have downloaded an old version of the 0.9.1.2 release as there were SVN issues with that release.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Plugin: W3 Total Cache] New version, something better, but minify STILL DOES NOT work for me!’ is closed to new replies.