WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: W3 Total Cache] Minifying Javascript from wp-includes

[Resolved] [Plugin: W3 Total Cache] Minifying Javascript from wp-includes

  • I’ve found an interesting problem where minifying the Javascript files loaded from the wp-includes folder causes breaks throughout the site. I’ve tried several combinations of settings and still have not seen it succesful. Anyone else have this problem? Did you solve it? If so how?

    Files is question are:
    /wp-includes/js/prototype.js?ver=1.6
    /wp-includes/js/scriptaculous/wp-scriptaculous.js?ver=1.8.0
    /wp-includes/js/scriptaculous/effects.js?ver=1.8.0
    /wp-includes/js/jquery/jquery.js?ver=1.3.2′

Viewing 2 replies - 1 through 2 (of 2 total)
  • I resolved this by:

    1. Adding the files to the minification list, but specifying “Embed in Header”
    2. On the JS Minify Settings -> selected “Combine only (Head)”

    That allowed me to fully minify the other files and embed them in the footer while preserving these troublesome files.

    Well done.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] Minifying Javascript from wp-includes’ is closed to new replies.
Skip to toolbar