WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] Minify only working on two of three blogs

[Plugin: W3 Total Cache] Minify only working on two of three blogs

  • This is a little complicated and difficult to explain: I currently have three WordPress installations across two GoDaddy shared Linux accounts. One installation is in the top directory of account alpha and everything works great.

    One of the other installations is in the top directory of the account bravo and that one works great too. Now, the problem comes with the installation that’s in a subdirectory of account bravo. I’m not sure how many people are familiar with the way you setup domain names in GoDaddy’s hosting management system, but you ‘point’ the domain to the subdirectory.

    I’ve done that and it works, but a problem arises with W3 Total Cache. The pages cache and that’s good but when I try to add the theme’s .css file in the minify settings, it doesn’t work. I hit ‘new’, paste the URI from the source code, and hit verify URI, and it’s all good. I hit save and try to the load the page…and no CSS. I click on the link for the where the CSS is supposed to be coming from (wp-content/w3tc/min/default.include.css) but that’s a WordPress not found page instead of the CSS. I checked the folder in FileZilla and the folder is blank besides a .htaccess and a PHP file.

    Is there some reason that the W3TC isn’t creating the files? Is there a problem because this folder is in a subdirectory and is it possible that’s causing a problem (either through mod_rewrite problems or something)?

Viewing 15 replies - 1 through 15 (of 28 total)
  • Try the latest release of W3TC.

    Well, I upgraded to the latest version on the top-level installation on account bravo and now the minification is FUBAR on that installation too. I think it doesn’t like the new forced relative paths method or something, from the minify debug:

    <!-- W3 Total Cache: Minify debug info:
    Engine:             disk
    Group:              index
    Stylesheet info:
       Location     |    Last modified    |         Size | Path
        include     | 1970-01-01 00:00:00 |              | home/content/c/o/r/corranh96blogs/html/wp-content/themes/blueline-10/style.css
        include     | 1970-01-01 00:00:00 |              | home/content/c/o/r/corranh96blogs/html/wp-content/plugins/cforms/styling/cforms.css
    JavaScript info:
       Location     |    Last modified    |         Size | Path
        include     | 1970-01-01 00:00:00 |              | /home/content/c/o/r/corranh96blogs/html/home/content/c/o/r/corranh96blogs/html/wp-includes/js/jquery/jquery.js
        include     | 1970-01-01 00:00:00 |              | /home/content/c/o/r/corranh96blogs/html/home/content/c/o/r/corranh96blogs/html/wp-content/plugins/google-analyticator/external-tracking.min.js
        include     | 1970-01-01 00:00:00 |              | /home/content/c/o/r/corranh96blogs/html/home/content/c/o/r/corranh96blogs/html/wp-content/plugins/cforms/js/cforms.js
        include     | 2010-03-14 03:31:37 |         9276 | http://www.statcounter.com/counter/counter_xhtml.js (/home/content/c/o/r/corranh96blogs/html/wp-content/w3tc/min/minify_fe1419d49448b1c796448a5ae330003d.js)
    include-footer  | 1970-01-01 00:00:00 |              | /home/content/c/o/r/corranh96blogs/html/home/content/c/o/r/corranh96blogs/html/wp-content/plugins/audio-player/assets/audio-player.js
    include-footer  | 1970-01-01 00:00:00 |              | /home/content/c/o/r/corranh96blogs/html/home/content/c/o/r/corranh96blogs/html/wp-content/plugins/flv-embed/swfobject.js
    include-footer  | 2010-03-14 03:31:37 |        49606 | http://static.addtoany.com/menu/feed.js (/home/content/c/o/r/corranh96blogs/html/wp-content/w3tc/min/minify_16876125c33571113290134dd8877dac.js)
    include-footer  | 2010-03-14 03:31:37 |        53295 | http://static.addtoany.com/menu/page.js (/home/content/c/o/r/corranh96blogs/html/wp-content/w3tc/min/minify_77f65729aca33be9e482b6a5b3520c40.js)
    -->

    Why are you using the document root file paths in minify?

    Only relative and absolute paths should be used. that is why you see the size is unknown for files not using absolute (with http://) or relative paths (relative to blog installation path e.g.: wp-content/subdir/file.js)

    I didn’t enter the files with relative paths, they had the full URIs but when I hit save, or modify any settings on the minify settings page, “http://www.imsurroundedbyidiots.com/wp-content/themes/blueline-10/style.css” was stripped down to “wp-content/themes/blueline-10/style.css”.

    That’s the expected behavior. I think it’s best to submit a bug submission form via the support tab so I can look at your particular situation.

    Just to let you know, Im getting the same EXACTLY problem with MediaTemple. W3 was working before but now the files are not being created. The debug output is exaclty the same from CorranH96 (no file sizes and stuff)

    I am getting this issue too..
    Everything were working as usual, and by updating to new version of W3TC minify paths got some bugs..

    In minify tab, settings are:

    JS:
    wblog/wp-includes/js/jquery/jquery.js
    wblog/wp-includes/js/jquery/jquery.form.js
    wblog/wp-content/plugins/contact-form-7/scripts.js
    CSS:
    wblog/wp-content/themes/GreenLeaves/rtl.css
    wblog/wp-content/themes/GreenLeaves/style.css
    wblog/wp-content/themes/GreenLeaves/style-ie.css
    wblog/wp-content/themes/GreenLeaves/style-ie6.css
    wblog/wp-content/plugins/contact-form-7/styles.css

    and debug shows this:

    Stylesheet info:
       Location     |    Last modified    |         Size | Path
        include     | 1970-01-01 00:00:00 |              | usr/wblog/wp-content/themes/GreenLeaves/rtl.css
        include     | 1970-01-01 00:00:00 |              | usr/wblog/wp-content/themes/GreenLeaves/style.css
        include     | 1970-01-01 00:00:00 |              | usr/wblog/wp-content/themes/GreenLeaves/style-ie.css
        include     | 1970-01-01 00:00:00 |              | usr/wblog/wp-content/themes/GreenLeaves/style-ie6.css
        include     | 1970-01-01 00:00:00 |              | usr/wblog/wp-content/plugins/contact-form-7/styles.css
    JavaScript info:
       Location     |    Last modified    |         Size | Path
      include-nb    | 1970-01-01 00:00:00 |              | /usr/www/virtual/username/www.domainname.net/wblog/usr/wblog/wp-includes/js/jquery/jquery.js
      include-nb    | 1970-01-01 00:00:00 |              | /usr/www/virtual/username/www.domainname.net/wblog/usr/wblog/wp-includes/js/jquery/jquery.form.js
    include-footer-nb | 1970-01-01 00:00:00 |              | /usr/www/virtual/username/www.domainname.net/wblog/usr/wblog/wp-content/plugins/contact-form-7/scripts.js

    I tried to use paths like http://www.domainname.net/wblog/usr/wblog/wp-includes/js/jquery/jquery.js but W3TC strips it down to wblog/wp-includes/js/jquery/jquery.js.

    Then i tried by adding /wblog/wp-includes/js/jquery/jquery.js or //wblog/wp-includes/js/jquery/jquery.js but then it URI check don’t work.
    I will try now to get around and try to save with /wblog/wp-includes/js/jquery/jquery.js setting..

    Without success…
    Also to mention, W3TC is adding an extra /usr/ before wblog/ , and that directory doesn’t exist..

    That directory may exist, it just might not be visible to you, especially if you’re on a shared (non-dedicated) server.

    I’ve unfortunately haven’t had time to file a bug submission yet.

    FYI: I’ve downgraded to the prior version in the mean time.

    Okay, I’ve filed a bug submission.

    Please check out the development version of W3TC and let me know if the problem persists:

    http://wordpress.org/extend/plugins/w3-total-cache/download/

    no no CorranH96.. This dir cannot exist, because WP is here: http://www.domainname.net/wblog not in http://www.domainname.net/usr/wblog.
    Probably it grabs it from /usr/www/virtual/username/www.domainname.net/wblog...

    @fredericktownes i will try now development version.

    Hi all
    I tried with development version.
    W3TC loads now CSS.

    But in debug mode, i can see that my DB queries are not cached nor minified, and my CSS and JS files too..

    <!-- W3 Total Cache: Minify debug info:
    Engine:             disk
    Group:              index
    Stylesheet info:
       Location     |    Last modified    |         Size | Path
        include     | 1970-01-01 00:00:00 |              | wblog/wp-content/themes/GreenLeaves/rtl.css
        include     | 1970-01-01 00:00:00 |              | wblog/wp-content/themes/GreenLeaves/style.css
        include     | 1970-01-01 00:00:00 |              | wblog/wp-content/themes/GreenLeaves/style-ie.css
        include     | 1970-01-01 00:00:00 |              | wblog/wp-content/themes/GreenLeaves/style-ie6.css
        include     | 1970-01-01 00:00:00 |              | wblog/wp-content/plugins/contact-form-7/styles.css
    JavaScript info:
       Location     |    Last modified    |         Size | Path
      include-nb    | 1970-01-01 00:00:00 |              | /usr/www/virtual/VPSuserName/www.MyDomainName.net/wblog/wblog/wp-includes/js/jquery/jquery.js
      include-nb    | 1970-01-01 00:00:00 |              | /usr/www/virtual/VPSuserName/www.MyDomainName.net/wblog/wblog/wp-includes/js/jquery/jquery.form.js
    include-footer-nb | 1970-01-01 00:00:00 |              | /usr/www/virtual/VPSuserName/www.MyDomainName.net/wblog/wblog/wp-content/plugins/contact-form-7/scripts.js
    include-footer-nb | 2010-03-17 17:45:21 |        24074 | http://www.google-analytics.com/ga.js (/usr/www/virtual/VPSuserName/www.MyDomainName.net/wblog/wp-content/w3tc/min/minify_d632339a4f2f04ee97ac859b9e728f09.js)
    -->
    
    <!-- W3 Total Cache: Db cache debug info:
    Engine:             disk
    Total queries:      16
    Cached queries:     0
    Total query time:   0.103
    SQL info:
        # | Time (s) |    Caching (Reject reason)     |   Status   | Query
        1 |    0.018 |  disabled (query is rejected)  | Not cached | SELECT option_name, option_value FROM wblog_options WHERE autoload = 'yes'
        2 |    0.001 |            enabled             | Not cached | SELECT * FROM wblog_users WHERE user_login = 'admin'
        3 |    0.002 |            enabled             | Not cached | SELECT meta_key, meta_value FROM wblog_usermeta WHERE user_id = 1
        4 |    0.027 |  disabled (query is rejected)  | Not cached | SELECT SQL_CALC_FOUND_ROWS  wblog_posts.* FROM wblog_posts  WHERE 1=1  AND wblog_posts.post_type = 'post' AND (wblog_posts.post_status = 'publish' OR wblog_posts.post_status = 'private')  ORDER BY wblog_posts.post_date DESC LIMIT 0, 12
        5 |    0.012 |  disabled (query is rejected)  | Not cached | SELECT FOUND_ROWS()
        6 |    0.001 |            enabled             | Not cached | SELECT t.*, tt.*, tr.object_id FROM wblog_terms AS t INNER JOIN wblog_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wblog_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category', 'post_tag') AND tr.object_id IN (1540, 1535, 1528, 1515, 1500, 1490, 1480, 1466, 1449, 1434, 751, 549) ORDER BY t.name ASC
        7 |    0.001 |            enabled             | Not cached | SELECT post_id, meta_key, meta_value FROM wblog_postmeta WHERE post_id IN (1540,1535,1528,1515,1500,1490,1480,1466,1449,1434,751,549)
        8 |    0.001 |            enabled             | Not cached | SELECT * FROM wblog_posts  WHERE (post_type = 'page' AND post_status = 'publish')     ORDER BY menu_order ASC
        9 |    0.002 |            enabled             | Not cached | SELECT * FROM wblog_ad_buttons WHERE
    	ad_active = 1 AND ad_strdat <= CURDATE() AND ad_enddat > CURDATE() OR
    	ad_active = 1 AND ad_strdat <= CURDATE() AND ad_enddat = '0000-00-00' ORDER BY ad_pos
       10 |    0.002 |  disabled (query is rejected)  | Not cached | UPDATE wblog_ad_buttons
    					SET ad_views = ad_views + 1 WHERE id = 2
       11 |    0.001 |  disabled (query is rejected)  | Not cached | INSERT INTO wblog_ad_buttons_stats(abs_dat, abs_ip, abs_view)
    				VALUES(CURDATE(), '1835727384', 2)
       12 |    0.005 |  disabled (query is rejected)  | Not cached | SELECT SQL_CALC_FOUND_ROWS  wblog_posts.* FROM wblog_posts  WHERE 1=1  AND wblog_posts.post_type = 'post' AND (wblog_posts.post_status = 'publish')  ORDER BY wblog_posts.post_date DESC LIMIT 0, 5
       13 |     0.01 |  disabled (query is rejected)  | Not cached | SELECT FOUND_ROWS()
       14 |    0.001 |            enabled             | Not cached | SELECT t.*, tt.* FROM wblog_terms AS t INNER JOIN wblog_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category')  AND tt.count > 0 ORDER BY t.name ASC
       15 |    0.001 |            enabled             | Not cached | SELECT t.*, tt.* FROM wblog_terms AS t INNER JOIN wblog_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('link_category')  AND ( t.term_id = 157 ) AND tt.count > 0 ORDER BY t.name ASC
       16 |     0.02 |            enabled             | Not cached | SELECT *    FROM wblog_links  INNER JOIN wblog_term_relationships AS tr ON (wblog_links.link_id = tr.object_id) INNER JOIN wblog_term_taxonomy as tt ON tt.term_taxonomy_id = tr.term_taxonomy_id WHERE 1=1 AND link_visible = 'Y'  AND ( tt.term_id = 157 ) AND taxonomy = 'link_category'    ORDER BY link_name ASC
    -->
    
    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk
    Key:                w3tc_5a0be98cb59c0389dc7a8796b33bf327_page_6666cd76f96956469e7be39d750cc7d9_gzip
    Caching:            enabled
    Status:             cached
    Creation Time:      0.003s
    Header info:
    X-Powered-By:       W3 Total Cache/0.8.5.2
    Pragma:             public
    Expires:            Thu, 18 Mar 2010 09:25:21 GMT
    Last-Modified:      Wed, 17 Mar 2010 17:45:20 GMT
    Cache-Control:      max-age=56150, public, must-revalidate, proxy-revalidate
    Vary:               Accept-Encoding, Cookie
    Etag:               442450c833ac497b20fd6131beba56be
    Content-Encoding:   gzip
    X-Pingback:         http://www.MyDomainName.net/wblog/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    -->

    Thanks in advance

    @yabate.

    That debug log looks normal for the first page after all caches are emptied. Possibly that is what you did?

    On the first request the queries are not cached. Of course, the second request will return the cached page – with exactly the same debug text.

    If you want to prove DB caching is working, turn off and empty the page cache and request the page. The next request – within the db cache expiration, of course – will show cached queries.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Plugin: W3 Total Cache] Minify only working on two of three blogs’ is closed to new replies.