W3 Total Cache
[resolved] Minify not working (BP 1.2.7 / W3TC (3 posts)

  1. mralexweber
    Posted 5 years ago #

    Hi Frederick,

    Thanks for the excellent plugin. I've used it successfully on other sites, but this new one is being difficult.

    Here's the problem:
    When adding css files to minify and enabling it, there are no errors.
    On my page, I can see a link to http://mysite.com/wp-content/w3tc-mysite.com/min/66ac5c/default.include.1829671923.css.
    When I try to view this file directly, I get a 404.
    When I look in the directory on my webserver (using Amazon EC2 btw) I see these files:

    /opt/wordpress-mu/wp-content/w3tc-mysite.com# ls -R
    min  pgcache
    _index.html  _index.html.gzip

    So I gather that these files were able to be created successfully, but I don't see any of the css minified.

    I also ran `cat w3tc-mysite.com/min/66ac5c/default.include.css.id' and got this back: 1829671923

    So it seems W3TC is getting pretty far along its process, but I'm guessing that it is failing to create the minified css at all. I've checked and the entire w3tc-mysite.com/ directory is owned to www-data (apache runs as this user) so that shouldn't be the problem... I think.

    Another troubleshooting step I took was disabling fancy URL rewriting on the "minify" page in W3TC. This changed the links on the pages to "ugly" URLs, but didn't fix the css issue. Also, I noticed that there was no "index.php" file present in w3tc-mysite.com/min/ or w3tc-mysite.com/min/66ac5c/... FFFFFUUUU >.<;

    As per the title, we're using BuddyPress and several other plugins. My suspicions are currently leaning towards some permissions/read/write issue, although I've tried changing most folders in the w3tc directory to 777 for testing purposes.

    Any ideas as to what might be causing this, before I try to figure out how to create a support account on my server and wp?


  2. mralexweber
    Posted 5 years ago #

    Also, I wanted to mention that I've tried this with a few different CSS files, since in other threads you mentioned that minify chokes on certain files. I've used 2 different ones (nothing special about them except they were large) and no luck. HTH

  3. mralexweber
    Posted 5 years ago #

    We were able to fix this issue by uninstalling and reinstalling W3TC.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic