Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Minify not working

  • wambamboo

    (@agatha1)


    Hi
    I’ve just installed the plugin but have the following error when enabling minify:

    “It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess. Or if using nginx verify all configuration files are included in the main configuration fail (and that you have reloaded / restarted nginx).”

    I have a .htaccess file in my installation.
    I’m just not sure how I would verify? There is no link on the error message.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 8 replies - 1 through 8 (of 8 total)
  • wambamboo

    (@agatha1)

    It also broke my CSS. Hmm. Deactivated.

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    WP Super Cache is much easier to get working and more reliable.

    wambamboo

    (@agatha1)

    Thanks will give it a go!

    Hans Worst

    (@reinierbutot)

    that message sometimes displays even when it is working!
    try viewing the source of your homepage, and look at the url to the css file(s),
    if it says somewhere “/minify/” or “minify.php”; click on that or go to that url and if you get the css then you know its working!

    Hans Worst

    (@reinierbutot)

    also, when using a translation plugin (WPML), that may break it.
    try turning off url rewriting for the minify option. that will probably fix it.

    btw: w3 total cache is a lot more powerful than wp super cache, just takes a little more attention when setting it up.

    johndoej

    (@johndoej)

    Are you running wordpress under http://domain.tld/sometihng/ ? I’m having problems with the exact same thing.

    If you don’t have it under /something/ and it’s directly on the root domain, then you’re having a different problem.

    Chris

    (@christianskalagmxat)

    I have a similar issue using nginx as reverse proxy in front of apache – here’s the ticket I created: http://wordpress.org/support/topic/combining-js-files-with-minify-not-working

    What I’m trying to achieve is to combine all JS files into one.

    Somewhere on the interwebs I found a post stating W3TC minify doesn’t work with nginx reverse proxy. Anybody can confirm this?

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    @chris: Don’t multipost, as per the Forum Rules. Dupe: http://wordpress.org/support/topic/combining-js-files-with-minify-not-working?replies=1

    @johndoej: It’s impolite to forum policy to interrupt another poster’s ongoing thread with a different question of your own. Please post your own topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: W3 Total Cache] Minify not working’ is closed to new replies.