Support » Fixing WordPress » [Plugin: W3 Total Cache] Minify driving me mad

  • So for the past two days I’ve been battling my way through getting W3TC setup and configured properly. I admit, it is more than likely my lack of understanding. But this is why I need some advice.

    I am currently running with WP 2.9.1 (latest as of the moment), ArrasTheme from and a few choice plugin’s in use on my site. I’ve successfully setup and configured Xcache on my PS with dreamhost and am pretty happy with the performance it offers.

    However when I get to the point of trying to configure the Minify settings I seem to be completely lost.

    The website I am currently working on is

    When Minify is completely disabled I can see within the head section in my source the following… Pastebin link

    Now please, feel free to correct me here at any point because this is where I think I’m just feeling around in the dark. I’ve been adding these CSS and JS path’s seen above in the code. I’ve been able to get it “functioning” however I then run into problems with the JS blocking page rendering. The lowest I’ve been able to get my load time is around 4.5 seconds up to 6 seconds.

    I know W3TC is actually working because I’ve benched it with’s testing service and even up to 50 concurrent simulated user’s the load time averages no more than 6 seconds. So like I said I know the PS is more than capable of the load, W3TC “is helping”. But my lack of know how with minify is preventing me from tuning the JS and CSS correctly.

    So I guess my question is am I just doing this completely wrong, am I on the right track? ANY advice at this point would be greatly appreciated, I can see the value in W3TC over the other choices out there and don’t want to go back because my lack of understanding.

    If you need any further info, please let me know and I’ll reply as soon as possible. Thanks in advance.


Viewing 14 replies - 1 through 14 (of 14 total)
  • I just looked at your site and I don’t see any CSS or JS minification done. For best results the development version of the plugin should be used:

    There are instructions on how to use minify in the plugin’s FAQ tab.

    I’ve actually been at it all morning so I’ve been in and out of the site. I’ve actually made some big progress. I think what I’m actually running into are issues with the theme itself.

    For instance, I’ve found that once I’ve added all my js files to the default template I CANNOT check the “Comment Removal” or “Line Break Removal” boxes without breaking my tabbed sidebar.

    Right now I’m trying to figure out where to add screen.css and print.css. If I add those two files into the default, Firefox renders the images with black borders. Chrome and IE 8 do not. But if I leave those two files out of the default on their own like normal everything seems to be kosher. If I put them into the header template, the black borders appear again. I think I may email the theme developer about that one some more unless you know of what might be the issue there, but I don’t expect that you should.

    But there is one thing you can answer for me, I’ve enabled the self hosted CDN on a separate subdomain. However Firebug shows no gzip compression for anything hosted on the self hosted CDN. even though gzip is enabled within wp-admin/w3tc settings and all pages coming from the normal site are gzip’d. I have an idea that it might be permission related considering I’m using two different users for the apache process.

    nevermind the gzip on the CDN thing, I just saw an earlier post in regards to the “_htaccess” file provided in the ini/ directory. Works like a charm

    Not all of the minify options are going to work on every site as the quality of coding varies from site to site and combination of code etc. It’s best to start with combine only if you’re having issues and then try other variations of options to try to reduce the files size further.

    I have been able to combine multiple css files into one, but not able to remove the comments and new line chars in css file. How do I go about it now? I have selected those options under css minify tab already.

    You must have checked, combine-only option?

    No Frederick, I have checked all the four:
    Combine only
    Comment removal
    Line break removal

    anything else I should be looking at?

    Played a bit with the combinations, I was able to combine and remove both comment and line break when I ‘UNCHECKED’ the option ‘Combine only’… weird!!!

    Can you submit a bug submission form from the support tab of the plugin?

    Done, I have sent the bug report.

    Did you receive my reply?

    is this bug solved

    No Frederick! I haven’t received any mail from you.

    Can you submit again then please?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: W3 Total Cache] Minify driving me mad’ is closed to new replies.