Support » Plugins » [Plugin: W3 Total Cache] Media library export

  • Resolved Cristian Antohe



    I’ve tried to setup W3TC with Amazon S3 but I have problems with the media gallery export.

    Some files are uploaded and some aren’t.

    I usually upload in the media gallery one file, then if it doesn’t look right I make modifications and reupload it with the same name. WordPress then just uploads it like so: 2010/01/my_file1.jpg (notice the ***1.jpeg part).

    From what I can tell these files aren’t uploaded to the CDN.

    Any ideas?

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Do you mean files with an underscore are not uploaded?

    No I mean files that I reupload in the media gallery and have the same name in the backend but different file name.

    I think it’s easier to send you a print screen:

    This happens when I upload a file that has the same name and date(so it’s positioned in the same 2010/01 folder for example) as one that already exists the media library. That generates same name, different filename.

    As far as i can see this has nothing to do with W3TC. The WP media library is not going to replace your files, it’s going to create a new file as it doesn’t assume that you are replacing one for the other. If you wanted to replace a file you would have to FTP the new image to replace the previous. Anyway, W3TC doesn’t even look for the label/title/name of a given attachment, there’s no bug surrounding the handling of images of the same name. Only file names are of any consequence.

    Check your failed transfers to see if the updated files are enqueued or not.

    There is nothing in the failed transfers.

    This is what I get when I upload the media library:

    wp-content/uploads/2010/01/galleryview1-150x150.jpg Unable to put object
    wp-content/uploads/2010/01/galleryview1.jpg Unable to put object
    wp-content/uploads/2010/01/galleryview-150x150.jpg Object already exists(this is correct since it's already on S3)
    wp-content/uploads/2010/01/galleryview.jpg Object already exists(this is correct since it's already on S3)

    I’ve tried to delete the first file galleryview.jpg and reuploaded the media gallery. It didn’t uploaded it to S3 and the error was

    wp-content/uploads/2010/01/galleryview1.jpg Unable to put object

    This is dumb I know, but I can’t see why it doesn’t upload these particular images.

    Here is the S3 bucket:
    And here is the image that is listed in the media library but doesn’t get uploaded in S3:

    Theoretically it should get uploaded but it doesn’t. I don’t know if this is something to do with W3TC, the server, S3 or my WordPress install (2.9.1).

    It’s just annoying. I don’t have a lot of images like so and I could most certainly manually reupload them.

    I’ve also tried to manually upload the galleryview1.jpg file using CloudBerry Explorer and it doesn’t work. I think in the end it’s a problem with the folder permissions because I can upload the file in the bucket’s root.

    Any suggestion is welcomed 🙂

    Does the ‘Test S3’ button work for you?

    Yes. The ‘Test S3’ button works and 99% of the media library is already on S3 as seen here

    I have some ideas why these particular files don’t get uploaded. The files wordpress renamed file might not have proper permissions on the server. I recently moved from a server where apache used the nobody user, to one that apache uses the ftp account to create and execute files. These old files have 99 permissions on the owner/group and that’s just weird I guess.

    I’ll look more into this problem but when I have more time. It’s not really that urgent right now to have CDN in place.

    Thank you for all your help!

    Ok, you can submit a bug submission form on the support tab of the plugin if you like.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: W3 Total Cache] Media library export’ is closed to new replies.