W3 Total Cache
Long lag time before page starts loading (8 posts)

  1. jacobstone
    Posted 3 years ago #

    I've just launched a site here: http://www.punch-drunk.com

    Installed W3 Total Cache, got all the basics going: page cache, minify, DB cache, object cache, browser cache - even setup a CDN with Amazon Cloudfront and uploaded all the various gallery images, attachments, include files, theme files, etc.

    Also have Cloudflare setup to further increase speed.

    The pages, once they start loading, load extremely quickly, but the issue is a 2-5 second (!) delay often between when you click a link for a page and it loads, where the status bar in the browser just says "Waiting for punch-drunk.com." (Mostly on Chrome OSX and WinXP, tried Safari and FF as well, same results)

    That lag time seems to decrease noticeably when I deactivate W3 total cache, but of course the pages themselves load more slowly then.

    Any ideas how to cut down this lag time? Thanks!



  2. jacobstone
    Posted 3 years ago #

    Note, I have W3 total cache deactivated at the moment for continued troubleshooting.

  3. haddow777
    Posted 3 years ago #

    Have you check out using a browser tool like Chrome's developer tools. If you use the network tab, you can see how your page loads. Each element, when the browser started loading that element, and how long each stage of its loading took.

    It even breaks each stage down into things like how long it took to resolve the DNS address, how long it took to send the request, etc.

    I know that W3TC increases load times when the web server doesn't load the cached file, but that is usually just a few hundred milliseconds.

    Your best bet is to use the previously mentioned tool (or a similar one) to see exacty what is taking so long. If it is W3TC generating a cache file, you should see that your top file, the HTML file, should be taking most of the time. Usually the substage "waiting" will be overly long, as your browser is waiting for WP to generate the page. If you find that some other element is taking forever, or you are getting a lot of failures/redirects, you can see if some configuration issues are happening.

    I once had a .htaccess rewrite loop happen that caused tonnes of 301 redirects on anything loading from my theme folder. Took forever to hunt that one down.

    Hope that helps some. Sorry it wasn't very specific, but I think more information is needed. Also, mention what web server you are using and whether you are on shared hosting or not. Thanks.

  4. jacobstone
    Posted 3 years ago #

    Thanks! I'll try that and report back. I did do a Yslow and Pagespeed - got an A in Yslow and 91 in Pagespeed. Those are down a bit now because I turned W3 cache back off, but will turn it back on later today and see if I can get more info via that method.

    The site is hosted at Mediatemple as a GS package.

  5. haddow777
    Posted 3 years ago #

    I don't know if this is related, but I just tried to load the mediatemple website to find out what a GS package is, and the page wouldn't load. White screen until Chrome asked me to kill it.

  6. jacobstone
    Posted 3 years ago #

    Weird, haven't had any other issues with MT. Still getting the huge lag, I have W3TC turned off at this point, hopefully will sort it out at some point though. Cheers!

  7. clayton_
    Posted 2 years ago #

    Was there ever any resolution to this issue? Others have asked the question without answer in other posts.

    I too have this problem. I have a 92 in page speed and a 90 is YSlow on gtmetrix.com - however my page load time is at 42 seconds... 40 of which is the initial GET request for the URL. "Waiting" on the server to jump takes forever.

    Shared hosting; I am also running cloudflare. And was having great results with it prior to turning on W3 Total Cache (2-3s Waiting time). I have also disabled Page Caching such that only object and browser caching is turned on (minification is handled by Cloudflare, though W3 does combine my 14 stylesheets into one first).

    Any help at all is much appreciated. Great plugin! I have a feeling initial caching or shared hosting might be the culprit, but any insights from those who have gone before me is a great help.

  8. I too have this problem.

    And a lot has happened in 7 months too in the 7 months that this thread has been hanging around.

    Can you please start your own topic with your own specifics? It's really the best way to get support for the problem you are having on your setup.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic