WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: W3 Total Cache] JS File Management:

[Resolved] [Plugin: W3 Total Cache] JS File Management:

Viewing 15 replies - 1 through 15 (of 21 total)
  • Do you have the very latest build installed? You might want to back up your settings file uninstall and pull down the latest build again.

    Dominik Schilling (ocean90)

    @ocean90

    WordPress Core Committer

    Thx, it works now.

    i’m having the same problem. i un-installed, deleted and re-installed but the problem persists. I am using 2.8.5. I noticed that it only does this when the ’embed’ selector is the same. I.E. if one of the js files is ‘footer’ and the second is ‘footer (non-blocking)’ they will remain but more than one in any category get stripped.

    Also minify for css seems to (IDK) fail to convert properly. Viewing the default.include.css reveals an assortment of random characters which in turn leads to the css not working on the page.

    any ideas? thx

    ian

    Dominik Schilling (ocean90)

    @ocean90

    WordPress Core Committer

    masterbassie, a solution for that is, to add the urls manual in the config file in /wp-content/w3-total-cache-config-xxxx.php.

    @ocean90 that seems to work well, thx.

    however i replicated this technique for the header and the js would not load. which made me doubt that the js in the footer was actually loading loading. i found that both the footer and header get “HTTP/1.0 400 Bad Request” which fail to load anything.

    any ideas why this is so?

    It means that the file you added to settings could not be access to build the cache or you do not have any settings for the requested file name.

    uh ok.. what i got out of that is the file could not be loaded, right? So then that limits the functionality of the combine in header or footer… or are you saying my settings are wrong?

    if so do you have any suggestions for what they should be or which js files should be included in this combine function and which should not?

    thanks in advance

    Right, try combine only and see how that works. The 400 error only occurs when there are no settings for the requested file type or if there’s a “bad” file in the settings causing minify to fail to create the file according to your settings.

    i tried the combine only but the same thing happened. the file itself wp-content/w3tc/default.include-footer-nb.js is not created (if i search for it in the above directory).

    permissions issue?

    If other files are created then it’s not a permissions issue. If the file is not available via the various download methods it will fail. Check the w3tc/log/minify.log

    it says [Mon, 09 Nov 2009 08:09:48 -0700] [/staging/wp-content/w3tc/default.include-footer-nb.js] Unable to download URL:….both files.

    i managed to figure out what was restricting the plugin from downloading the js – this plugin is on my staging site which is in a password protected directory. i took of the password and it loaded.

    problem now is the js seems to not be working. with the combine only function enabled what should ‘default.include-footer-nb.js’ look like? I would imagine just both js in one file.

    Instead it looks like this’��������;ks�ʒ��_1�n�’. i cleared the cache but it didn’t change it. I’m using apc on bluehost if that matters.

    ideas?

    There’s still not enough information. A link to phpinfo(); page?

    http://www.ilivesalsa.com/phpinfo.php

    this isn’t the staging site directory but the info should be the same…. i think

    Bluehost has a lot of anomalies (in my experience). This issue may require a staging site be made available for testing. Are you amenable to that?

    I’m also having the issue where multiple JS files can’t be embedded in the same container (i’m using W3TC 0.8). Two files can be embedded independently without problems, but when i try to embed both simultaneously in the Footer one of them is always purged. Any ideas?

    Other than that, wonderful plugin, this brought Mysql load down from ~300 to ~30 queries/second on our site (and there’s still some more optimizing to do). Thanks!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] JS File Management:’ is closed to new replies.
Skip to toolbar