Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] It appears Page Cache URL rewriting is not working. SOLVED

  • OK. I am dumb. I am posting this in case someone else has this happen to them in hopes it saves them some time.

    I was moving wp from one server to another. Left the old copy on the old server running until I could get wp installed on the new box.

    I changed my local pc’s hosts file to point the domain to the new box for testing.

    Everything seemed great and working fine but that dang “It appears Page Cache URL rewriting is not working.” error kept showing up. I don’t want to say how long it took to figure this out. Nor how many times I created new files and or reinstalled the plugin.

    Here’s the bottom-line…. The script tries to fetch a url on the site If it can reach it then everything is set. If it can’t reach it then it throws the error message.

    my local hosts file was pointing to the new box. the new box was trying to fetch from the old box. so it could not reach the test url. Who knows why it can’t reach it on the old box but i don’t care at this point.

    The moral of the story is… if you get that error and nothing seems to make sense ask yourself a question. is the server you are installing on trying to reach the url on itself or not.

    You can reply back with all the wise cracks you want. cause i won’t be checking for follow-ups haha.

  • The topic ‘[Plugin: W3 Total Cache] It appears Page Cache URL rewriting is not working. SOLVED’ is closed to new replies.