Support » Plugins » [Plugin: W3 Total Cache] is breaking my RSS feed

  • Hi,

    Whenever I have the W3TC plugin enabled, my RSS feed breaks with this error:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://meeble.com/feed
    Line Number 2, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>

    As soon as I disable the plugin, the feed goes back to normal. Is this a bug with W3TC? Why is it adding a blank line to the top of my RSS XML feed?

    Also, I have tried enabling one type of caching at a time – as soon as I enable any one type of caching, my RSS feed breaks again.

    Ideas? Is there an official bug reporting site for W3TC?

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • is anyone else experiencing this?

    Did you file a bug report from the Support page in the plugin?

    It would be helpful to know your settings in order to give some advice.

    I am experiencing the same issue. With W3 Total Cache enabled I get the a malformed XML error, given by the first line being empty.

    My W3 Total Cache settings are:
    – Page Cache: enabled
    – Minify, Database, Object, Browser cache: disabled

    Page cache settings:
    – Home page: enabled
    – Feeds: disabled (it seems to me this has no real effect)
    – SSL: enabled
    – 404: disabled
    – hostname: enabled
    – don’t cache logged is users: enabled

    Actually I solved with an hack of WP index.php as suggested here.

    And deactivating the plugin got rid of the issue as well?

    Yes, when I disabled W3 Total Cache I got rid of the problem. Anyway I am not totally sure that it was strictly related to W3 Total Cache itself. In the meantime I updated a bunch of plugins and I made some new tests. It looks like now everything works fine again even without the whitespacefix hack and keeping W3 Total Cache enabled.
    I will let you know if the issue will occur again.

    Ok great, can you please mark this issue as resolved?

    Sorry I cannot mark it as resolved since the thread was not opened by me.

    Anyone?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: W3 Total Cache] is breaking my RSS feed’ is closed to new replies.