WordPress.org

Forums

W3 Total Cache
[resolved] I upgraded my WordPress to 3.3.2 then w3tc is throwing error (13 posts)

  1. kalapam
    Member
    Posted 3 years ago #

    I'm getting the following error on w3 total cache after upgraded to 3.3.2:

    Page caching is not available. The current add-in /home/site/public_html/wp-content/advanced-cache.php is either an incorrect file or an old version. De-activate the plugin, remove the file, then activate the plugin again.

    I have backup the config file and reinstalled the plugin and i'm getting the same error. Any idea how to fix this?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did you already try deactivating and re-activating the plugin? It will re-create missing files normally if it has the permissions to. Otherwise you'd have to re-install (your settings won't be lost unless you manually delete the settings file).

  3. Andrea Pernici
    Member
    Posted 2 years ago #

    I have the same problem and I have folder permission.

    I'm using mod_php

  4. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Which version of the plugin?

  5. TammyG
    Member
    Posted 2 years ago #

    Same error for me, site http://www.goffstownlibrary.com
    WordPress 3.5.1.
    latest w3tc

  6. TammyG
    Member
    Posted 2 years ago #

    Somehow I've resolved this.

  7. Daniel Sachs
    Member
    Posted 2 years ago #

    Same errors here on advanced-cache.php and db.php

  8. TammyG
    Member
    Posted 2 years ago #

    fyi:
    De-activated w3tc, then uninstalled. I had another caching program - deactivated it. (Saw this - https://wordpress.org/support/topic/site-not-working-after-update-1?replies=5 - ...tried removing the wp-content dropins? advanced-cache.php, db.php and object-cache.php ...)
    Re-installed, activated & so far, so good.

  9. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Latest means 0.9.2.7?

  10. Daniel Sachs
    Member
    Posted 2 years ago #

    Yes,
    Also 0.9.2.6
    What I did:

    chmod 777 on wp-content, .htaccess and wp-config.
    Activated plugin.
    Errors appear.

    Deactivated.
    searched for files in question. > No files found

    Activated.
    Same errors.

    Uninstalled
    chmod back to previous settings

    Installed again without chmod - same errors.

    If you need any server logs or configuration or any other info, let me know.

    Thanks for your great plugin, your hard work is much appreciated!

  11. Sebastian Starke
    Member
    Posted 2 years ago #

    Same problem here.

  12. Sebastian Starke
    Member
    Posted 2 years ago #

    I tried the above, by the way.

  13. Sebastian Starke
    Member
    Posted 2 years ago #

    Upgrade to 0.9.2.8 seems to work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic