Support » Plugins » [Plugin: W3 Total Cache] How to Uninstall with no Admin Panel

  • Hi, I am trying to figure out how to get my WP administration panel back. When visiting the site the screen is blank. I have tried un-activating all the plugins through phpmyadmin, but the white screen persist. I have reason to believe it may be the W3 Total Cache plugin.

    How can I uninstall this plugin manually? I have tried deleting all the files in the plug-in folder as well.

    The WWW version of my site works fine. The non WWW version shows a blank screen. Trying to access the administration panel from either route retrieves a blank screen.

    Any ideas would be very welcomed as we can’t edit the site like this. (


Viewing 15 replies - 16 through 30 (of 56 total)
  • After removing: advanced-cache.php, db.php, w3tc/, w3-total-cache-config.php from wp-content/ in addition to wp-content/plugins/w3-total-cache/

    my problem did not go away immediately. I deleted the additional W3 hooks (references)that were in /wp-content and my problem is now resolved.

    @spunko2010, I could not reply to your email, it bounced:

    Yes, If you update “Store uploads in this folder” in /wp-admin/options-media.php to any other value and save, and then change it back to the correct value and save again that will update the database.

    I am having the same problem with my administration screen after installing and then uninstalling w3. However this file advanced-cache.php was deleted as a consequence of attempting to delete the plug-in from within WordPress after I got the message about the fatal error. Therefore, there don’t appear to be any w3 hooks in my wp-content/plugins directory.

    What is the best way to procede Frederick?

    Also, if WP continues to list a non 3.0 compliant plug in as a the “hot” plug in you are going to continue to get people installing your plug in and dropping their admin panel. I would contact WP on this topic. I installed this plug int because it was listed in my admin panel.



    More instructions aside from simply removing files from the plugin directory should be forthcoming. This does not work in all cases, and has not worked in mine. W3 must be affecting aras outside of he plugin directory as I have renamed the entire directory as recommended in the link listed above, and created a new plug-in directory and I still have no admin panel.



    I’m not sure how you’re arriving at these conclusions. I think we already have an email dialog going @supersnapp. So will continue there for now.

    Ok, I finally got this plugin working (this was by far the most confusing and cumbersome plugin I’ve ever installed…and I’ve installed hundreds of WP sites) and it appears to work great. But now when I try to login to my wp-admin area I can’t?

    Reading this suggests that after all that work I need to now hack up my worpress install and remove it from the site which seems a bit extreme.

    Instead, I’d like to know if this will be WP 3.0.1 compatible anytime soon? Or is there a link to show how I can access my wp-admin area and continue using the plugin?


    @dennysugar it already is. Check out the description page of the plugin, most people are doing ok. You likely have a conflict with your theme or another installed plugin. You can try changing the active theme or disabling other plugins to identify the conflict.

    I had an issue that when I deactivated the plugin; it was still working. I then removed the plugin folder and got the admin errors. However, like Fredrick says, remove ALL the W3 Total Cache files and you should be good to go.


    Once those files were deleted, the admin errors went away.

    I also dropped the DB table that related to the plugin.

    Hi Frederick

    Thank you for developing the W3-Total-Cahe plugin. The concept is great and I hope the bugs will be fixed so that we can enjoy the benefits.

    I did run into issues after installing the plugin. The first probloem i noticed was that some post links were leading to 404 error (Page Cannot be displayed error). I tried changing the settings, but did not get anywhere. So i decided to uninstall the plugin. I deleted all files as suggested, but still the links do not work if i use Custom permalinks. I reprovisioned my Virtual Dedicated Server, reinstalled database and wordpress, but sill Custom Permalinks are leading to 404 errors while clicking links to posts, categories or archives. I notice that the Apache Web Server is reporting errors when accessing the posts through custom permalinks.

    For some reason. the W3 Total Cache changed the PHP processing by the Web Server. Is there any documentation available that will explain what the W3 Total Cache updates when enabling “Page Cache”?

    I would like to use this plugin since the benefits are great. Just need the information on how it is designed so that I can fix the issues. Thank You.

    There will always be bugs in any software. All of that was completely unnecessary, did you check your .htaccess file to see if the W3TC rules were removed when you deactivated (which is what normally happens)? If you have any other custom rules in the file they can interfere with caching so unknown quantities make it impossible to make a perfect product.

    I almost convinced myself that I was included in the list of people who “tried everything” to uninstall. After going through two pages of google searches on how to uninstall the plugin, I sat back, took a deep breath, and just thought for a second.

    I then browsed around my site directories via ftp and found a second .htaccess file a level up from the wordpress installation. I had overlooked this one because I had already removed the WT3 additions from the .htaccess file in the wp install directory. Turns out that this one was a WT3 addition as well, and my wp was fixed after I removed those additions.

    Overall, it was a VERY easy fix, but it sure did take a while to figure out what was wrong (finding the second .htaccess file). I learned a lot during the process after reading articles about cache, so this whole “headache” was actually worthwhile and will be critical to know in the future.

    Here is what I did to fix MY problems:
    – Delete plugin folder via ftp and all the other files as mentioned in above posts.
    – Delete WT3 additions in the wp-config.php
    – Find every .htaccess file in your site (I found two), from the wp folder to the site root, and remove the WT3 additions.
    – Upload and refresh.

    I hope this helps the next person that ends up exactly where I was.

    Finally i resolved my permalink issues by changing the following in the Apache HTTP Server conf file. Surprisingly I noticed that the AllowOverride was set to None when i checked it after uninstalling W3 Total Cache.


    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be “All”, “None”, or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    AllowOverride All

    I believe there is no way that W3 Total Cache would have changed this value. May be its a coincidence that my hosting provided has changed it without my notice.

    Fred – do you know if the plugin would touch the Apache configuration?

    Are there any detailed documentation available (for setting up W3TC) ? I guess more people will use this plugin if only there is more documentation available. Thank You.

    One other thing that I’ve been noticing, wp-content/w3tc/ has permissions that exceed any that I have via FTP or CPanel. I’ve had to ask the host to remove this folder for me.

    Is that normal?

    do you know if the plugin would touch the Apache configuration?

    No it doesn’t change that setting. It can’t in fact.

    Are there any detailed documentation available (for setting up W3TC) ?

    I don’t know what to say. I have 3 choices: 1. Remove all of the options and force people to optimize their sites as I desire. 2. Leave the options, keep reasonable defaults and let users read the captions and make their own discoveries. 3. Do #2 and write a 200 KB FAQ instead of my 100 KB one, trying to answer every conceivable question before it’s asked. Basically write a book.

    I’ve chosen some of #3. I try to update the FAQ as I can.

    One other thing that I’ve been noticing, wp-content/w3tc/ has permissions that exceed any that I have via FTP or CPanel.

    I don’t know what this means.

Viewing 15 replies - 16 through 30 (of 56 total)
  • The topic ‘[Plugin: W3 Total Cache] How to Uninstall with no Admin Panel’ is closed to new replies.