WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » [Resolved] [Plugin: W3 Total Cache] how to force load file from my server and not CDN

[Resolved] [Plugin: W3 Total Cache] how to force load file from my server and not CDN

  • I have a Amazon S3 CDN set up, but I want to load some font files from my server instead of the CDN. They were uploaded once, so I just changed the name of the font files in my css and the server filesystem.

    But it still tries to fetch the file from the CDN, and obviously cannot find it.

    How do I make an exception about loading resources from the CDN, and just make it fetch from my server itself?

    The reason why I want to do this is because firefox needs a specific header(access control) sent out with font files sent from an absolute URL in a @font-face rule for it to use the font.

    I am not very good with CDNs. Infact, I am just using a friend’s, so I don’t know how to change the header of the response.

    I would much rather just load a few files from my server itself.

    Any way I can do this?

    EDIT: Wow.. How could I miss that box in the CDN options page? Please don’t mind folks. Nothing to see here.

Viewing 1 replies (of 1 total)
  • Plugin Author Frederick Townes

    @fredericktownes

    Remove the file suffixes from the “File types to import” field on the CDN settings tab. Make sure that you don’t have any paths to your font files in the “Custom file list” field either. Save your settings and empty the cache.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] how to force load file from my server and not CDN’ is closed to new replies.
Skip to toolbar