W3 Total Cache
Home page caching although set not to? (4 posts)

  1. Ben Huson
    Posted 4 years ago #

    I do not seem to be able to configure W3TC to not cache the home page while caching other pages. Essentially my home page is highly dynamic and random, but all other pages are fairly static and can be cached.

    I have "Page Cache" enabled using "Disk: Basic"
    In the Page Cache General Settings I have unchecked the "Cache home page" option.

    However in the debug comment at the bottom of the home it says "Page Caching using disk: basic"

    I am using a static WordPress page as my home page.

    If I add "/" into "Never cache the following pages" is disables caching for all pages.

    What is the correct way to set this up?


  2. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    The homepage is not cached unless check box is checked. The HTML comment always says Page Caching using disk basic (for example). Sorry that's confusing.

    The timestamp in the Served from message should change - that's how you know the page is not cached.

  3. Ben Huson
    Posted 4 years ago #

    Sorry, I meant I HAD checked the home page option.

    Yes, I found the HTML comment always being presnt was confusing - I'll check the timestamps and see if that resolves my question.

    Many thanks

  4. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    Any result?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic