W3 Total Cache
[resolved] gzip works for .css and .js but not for .html (8 posts)

  1. titanas
    Posted 5 years ago #


    It's weird but it's happening. Gzip works just fine with all the .css and .js files but not with the html files server from my blog (www.pestaola.gr). Browser Cache is ON along with all the Enable HTTP (gzip) compression checked. Any ideas?

  2. Frederick Townes
    Plugin Author

    Posted 4 years ago #

    I think that this has been discussed via email and thus far it appears to be a web host issue.

  3. gusleig
    Posted 4 years ago #

    My host is Media Temple, did you get to solve this problem? I´m having the same issue with my dv server...

  4. Ken Storch
    Posted 4 years ago #

    I'm with Laughing Squid and having a comparable (?) issue.

    see: http://wordpress.org/support/topic/w3-total-cache-pages-dont-gzip-or-cache

  5. gusleig
    Posted 4 years ago #

    Ken, I managed to solve my issue. It was something about permissions. what I did:

    1. uninstalled the plugin,
    2. deleted all its folders,
    3. chmod 777 my wp-content,
    4. reinstalled w3tc

    Now its creating the gzip files. Like magic...

  6. Ken Storch
    Posted 4 years ago #

    Thanks for updating.
    I'm glad the chmod change worked for you
    That's not the source of my problem, alas.

  7. gusleig
    Posted 4 years ago #

    It wasnt just the chmod, because I tried before, uninstalling the plugin made all difference.
    good luck.

  8. Ken Storch
    Posted 4 years ago #

    I did try an uninstall/reinstall and it didn't help with the issue, alas.

    Thanks for responding, though. I appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic