[resolved] [Plugin: W3 Total Cache] gzip isn't working when using w3 total cache (3 posts)

  1. Cor van Noorloos
    Posted 5 years ago #


    Currently using the dev version of W3 Total Cache YSlow is giving me the following errors:

    Grade C on Compress components with gzip
    There are 2 plain text components that should be sent compressed


    I’ve tried adding

    # BEGIN HTTP Compression
    <IfModule mod_deflate.c>
    # Netscape 4.x has some problems...
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    # MSIE masquerades as Netscape, but it is fine
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won't work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    # Don't compress media or scripts
    SetEnvIfNoCase Request_URI (?:bmp|gif|jpe?g|php|png|swf|tiff?)$ no-gzip dont-vary
    # Make sure proxies don't deliver the wrong content
    Header append Vary User-Agent env=!dont-vary
    # Fragment size to be compressed at one time by zlib
    #DeflateBufferSize 4096
    # Amount of compression applied to output
    #DeflateCompressionLevel 9
    # How much memory should be used by zlib for compression
    #DeflateMemLevel 9
    # Zlib compression window size
    #DeflateWindowSize 15
    # Enable HTTP Compression policy for all except .css, .js and .html documents
    SetOutputFilter DEFLATE
    AddOutputFilterByType DEFLATE text/css text/plain text/html text/xml text/xsd text/xsl application/x-javascript \
    \. application/wlwmanifest+xml image/svg+xml image/x-icon
    # END HTTP Compression

    from the wp-content/plugins/w3-total-cache/ini/_htaccess file to my root .htaccess file, but without any improvements.

    Could someone tell if I might be overlooking something somewhere perhaps?

  2. Cor van Noorloos
    Posted 5 years ago #

    It seems CURL PHP support was missing. By enabling this it did seem to add some gzip related entries to my wp-content/w3tc/min/.htaccess file, but it still seems I'm overlooking something as things aren't being compressed yet.

  3. Cor van Noorloos
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.