Support » Plugins » [Plugin: W3 Total Cache] Full images not exported to CDN (subdomain via FTP)

  • The ‘Export to CDN’ in W3 Total Cache does not copy the “full images” over to CDN (I’m using subdomain as the self-hosted FTP CDN), only the WordPress generated thumbnails.

    For example, I’ve added a image to media library:
    image-in-media-library.jpg

    WordPress creates the “thumbnails” automatically, named something like this:
    image-in-media-library-300×300.jpg
    image-in-media-library-150×150.jpg

    When I use the “Export media library to CDN” the full images are not somehow recognized. Everything that is recognized moves OK (green), but all images on the list are the 300×300, 150×150, etc. thumbnails.

    (W3 Total Cache version is 0.8.5.2)

    [EDIT] I recently turned off the CDN, since I had to cleanup the subdomain, and this problem arised when I turned it back on and went to export stuff to sub-domain/CDN again. I think I did the earlier, successful export on WP 2.8.x or so. Now on the latest 2.9.2.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Did you try to start from scratch? I’m not clear on how things were ok then not. Please clarify.

    I had the W3 Total Cache, CDN, FTP path set to a directory in the subdomain I use as CDN. When I deleted that directory on the subdomain, and moved the FTP-path for CDN to the root of that subdomain, and tried to “re-populate” the subdomain CDN, full images were not copied…

    • I had FTP path as: /sub.example.com/wp (with media library succesfully exported into that directory on the subdomain)
    • I disabled the CDN on W3 Total Cache
    • I deleted the /sub.example.com/wp directory
    • I changed the FTP path on W3 Total Cache settings to /sub.example.com (root of the subdomain)
    • I enabled CDN on W3 Total Cache
    • I tried to “Export media library to CDN” (the now empty subdomain)
    • Only the thumbnail images were copied from wp-uploads
    • e.g. image.jpg was not copied, but the image-300×300.jpg and image-150×150.jpg WordPress had created on original upload were copied
    • Links to the full images that were not copied, point to CDN, but the file is not there (since it was not copied)

    Long story, but in short: seems like the media library export doesn’t recognize the full images (after changing the FTP path).

    This issue is resolved in the next release.

    When will this version be released?

    I am experiencing the same problem, everything is uploaded just nicely and if i active CDN it also works great except for images in their original size.

    If the release is not to be expected for a couple of weeks is it then possible to download a beta or can you tell me what changes to what files need to be made?

    You can contact me for the beta via my web site.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: W3 Total Cache] Full images not exported to CDN (subdomain via FTP)’ is closed to new replies.