W3 Total Cache
[resolved] Fatal PHP error for non-admin users (3 posts)

  1. jmozen
    Posted 3 years ago #

    Hi there -

    I'm getting the PHP out of memory error, but only for non-admin users:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 75 bytes) in /***/htdocs/wordpress/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php on line 5682

    I don't have access to the php.ini file at this hosting provider, so I've tried increasing the PHP memory from 32M to 64M in the wp-config file and in the .htaccess file, but neither option is making a difference.

    Everything works fine as long as I'm logged in as the admin user, but I wanted to create an account with editor level access for my client.

    Any suggestions?

    Thanks in advance for any help!!!


  2. jmozen
    Posted 3 years ago #

    I finally found a solution that works ...

    Add these two lines to wp-settings.php:

    define('WP_MEMORY_LIMIT', '64M');
    ini_set("memory_limit", "64M");

    I'm not sure why I was still having trouble after increasing the PHP memory limit using the wp-config.php file or the .htaccess file, but this one worked.

  3. guilliam
    Posted 3 years ago #

    thanks for this info :) got this similar issue as well after doing an update to the latest built a few minutes ago.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic