WordPress.org

Forums

[Plugin: W3 Total Cache] Fatal Error upon activation (16 posts)

  1. pachelbel
    Member
    Posted 5 years ago #

    I'm getting the following error when I try to activate the plugin:

    Plugin could not be activated because it triggered a fatal error.

    /wp-content/uploads could not be created, open_basedir restriction in effect, please check your php.ini settings:
    open_basedir = "/f5/mysite/:/nfsn/apps/php5/lib/php/:/nfsn/apps/php/lib/php/:/nfsn/content/content/nfsn/"then reactivate plugin.

    The directory /wp-content/uploads does exist and is chmod to 775. All WP directories are chmod to 775 and owned by me:web

    Please help. Thanks.

  2. Frederick Townes
    Member
    Posted 5 years ago #

    It appears there's an invalid open_basedir setting there in your PHP configuration. But anyway, try to # chmod 777 wp-content/uploads/

  3. obliviousinvestor
    Member
    Posted 4 years ago #

    When I update to the latest version of W3 Total Cache, I get a similar error -- only difference being the location it gives me for open_basedir = "......"

    wp-content/uploads/ already exists and is set to 777.

    Any suggestions for what to try?

    Thanks :)

  4. obliviousinvestor
    Member
    Posted 4 years ago #

    I should add: In case it matters, my site was recently migrated from Dreamhost to Media Temple dedicated virtual, and PHP "safe mode" is set to OFF at the moment.

  5. DLCW
    Member
    Posted 4 years ago #

    I'm getting the same fatal error problem when I updated. Nothing has been changed on my site other then feedback messages to my blog posts. Is there a way to undue this 'upgrade' and go back to a previous version? I'm not a technical person - I'm a professional cabinet/furniture maker, so replies of a technical nature will go right over my head.

    Thank you :-)

  6. obliviousinvestor
    Member
    Posted 4 years ago #

    Alternatively, if I try to install the development version, I get the following error:

    Unable to create directory /home/.pru/heffern/obliviousinvestor.com/wp-content/uploads/2010/09. Is its parent directory writable by the server?

    (Don't know if it's significant that I could install 9.1.2 but not activate it, whereas the development version I can't install at all.)

  7. Sjeng
    Member
    Posted 4 years ago #

    on WP3.0.1:
    Fatal error: Cannot redeclare w3_activate_error() (previously declared in /var/www/[mysiteurl]/_/htdocs/wp-content/plugins/w3-total-cache/inc/define.php:64) in /var/www/[mysiteurl]/_/htdocs/wp-content/plugins/w3-total-cache-0912/inc/define.php on line 89

    Any help???

  8. efikim
    Member
    Posted 4 years ago #

    looks like you've got two copies of W3TC installed

  9. Sjeng
    Member
    Posted 4 years ago #

    Thanks very much. It seems the directory MUST be named w3-total-cache, and no others may co-exist, even if they are deactivated.
    I usually name my subfolders, deactivate the old plugin, activate the new one to see if it works, then delete the old folder.

    Thanks, worked fine now.

  10. Frederick Townes
    Member
    Posted 4 years ago #

    @obliviousinvestor please re-download the latest release and try again.

  11. cesar130177
    Member
    Posted 4 years ago #

    I have similar problems:

    WordPress Resources
    /public_html/contents: Write-able
    /public_html/.htaccess Write-able
    Uploads directory: Error: No se pudo crear el directorio /uploads/2010/11. Asegúrate de que el servidor tiene permisos de escritura para el directorio superior.
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off
    Legend

    ------------------

    I have 775 permissions to /uploads folder and subfolders. Activate and reactivate unsuccessfully. Any idea?

    I am using subdomains for public URLs to multimedia, contents, etc. Could this be the problem?

    Thanks,

    César

  12. Frederick Townes
    Member
    Posted 4 years ago #

    W3TC cannot find your uploads directory, could you go to the media settings tab and then change the value for uploads to anything other than the default, save the settings then restore the default (wp-content/uploads) once more and save again. Then deactivate and re-activate W3 Total Cache.

  13. derrick9
    Member
    Posted 4 years ago #

    Frederick when I attempt to activate W3TC I get a fatal error message.

    Here it is:

    Plugin could not be activated because it triggered a fatal error.

    I uploaded it from the WordPress.org Plugins repository. I was following instructions but based on WordPress advice I didn't mess with permissions because apparently I don't have to:

    NOTE: For the Automatic Upgrade/Install of Plugins/Themes and WordPress Upgrades, No special permissions need to be set. All WordPress files should remain owned by your user account (the user account the httpd runs as), You should NOT have to make them world writable(777). If you attempt to change the ownership/permissions of files in order to allow the upgrader to work, There is a high chance of bugs/issues poping up related to the incorrect permission scheme chosen.

    I did have WP Super Cache but I deleted it per instructions. But I'm still a beginner at this and wondering if I didn't do it correctly and it could be causing the activation error. I'm at a loss. Help!

  14. Frederick Townes
    Member
    Posted 4 years ago #

    Do you know how to check your error log are there any errors in it at the time of activation? You can contact me through my web site for more help.

  15. derrick9
    Member
    Posted 4 years ago #

    Hey Frederick,

    Thanks so much for getting back with me. I will check the error logs and see if there were errors at the time of activation. And I'll f/u with you on your Web site. Thanks so much.

    Derrick

  16. Frederick Townes
    Member
    Posted 4 years ago #

    Ok.

Topic Closed

This topic has been closed to new replies.

About this Topic