Support » Plugins » [Plugin: W3 Total Cache] Error: Unable to list buckets

  • Resolved yoren


    After upgrade to, I can’t upload files to S3.

    When I use “Test S3 Upload”, the error message said:
    “Test failed. Error: Unable to list buckets (check your credentials).”

    But I’m sure my credentials are fine, coz I could upload to S3 via Transmit with the same key.

    Anyone has ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Can you confirm that cURL is available by checking the output of phpinfo(): ?

    Yes, the cURL is enabled on my server, and the previous version worked very well, except I got the same problem as:, that’s why I upgraded to .8.5.2.

    The AWS implementation has not changed in this release. Please submit a bug submission from the support tab of the plugin.

    I’m having the same error message. If there is any resolution to this thread, please let me know. After trying many different variations, and making sure I’d followed the directions, I gave up.

    I don’t know about cURL, but my webhost always seems to have everything (Westhost). I wonder if Amazon made a small change.

    I’d love to get this working…

    There’s not a known bug with this so if you want help you’ll need to submit a bug submission report from the support tab of the plugin.

    After I corrected the server time, which was 16 mins late, the problem resolved.

    Wow, that was an interesting one. Well done.

    Can either of you tell me how to check and correct the server time? I’m on a virtual hosted server. My WordPress blog is set to Japan time, but my host is located in the USA…could that cause such a server time issue?

    Then again, if the difference between time zones is the problem, it will be easier to change my time in WordPress to match my host rather than to mess with the changing the server time. Maybe I’ll try this, but if either of you can offer advice I’ll be grateful. Thanks.

    Sorry for repeated posts. I tried changing my time zone in WordPress to match the location of my host, but I’m still getting the same error message. Still stuck here.

    I used the Firefox add-on ‘S3 Organizer’ to solve this.
    It is available here:

    Once I had the add-on installed, I went to Tools –> S3 Organizer
    I supplied the add-on with my credentials from Amazon S3, and then created a ‘Bucket’.

    I could then use that Bucket name with W3 Total Cache with no problems.

    I also installed the Firefox add-on, but I couldn’t get the bucket I created to work. But THEN I tried to use W3 Total Cache to make a bucket (one last attempt…) and it worked. I wonder if installing the add-on helped, or if Frederick might have worked on my blog and fixed something already (I had submitted a ticket).

    Now my problem is that large images aren’t displaying. The source HTML uses the original name of the file, but the files on Cloudfront have a different name as mentioned here:

    The issue with timezone would be with PHP configuration itself, you need to contact your web host about it. Make sure you’re using the development version of W3TC.

    This is an interesting problem because I do have the time properly configured on the server and PHP is configured to use UTC and I do encounter the same issue.

    Then there’s a different issue to sort. You can submit a bug submission form from the support tab of the plugin.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: W3 Total Cache] Error: Unable to list buckets’ is closed to new replies.