W3 Total Cache
Error: Unable to list buckets (). with CloudFront (4 posts)

  1. ArchieOpteryx
    Posted 5 years ago #

    I'm trying set up W3 Total Cache's CDN support with Amazon CloudFront but I'm getting an error message "Error: Unable to list buckets ()." when I try to test the configuration.

    I've searched for anyone else reporting similar problems and I have checked the timezone for the server (GMT using phpinfo) and in WordPress it is set to London. The time is correctly set, I checked that via a phpinfo() and checking _SERVER["REQUEST_TIME"].

    cURL support is enabled, again checked via phpinfo()

    And I created the first CloudFront bucket on Amazon's AWS Management Console, as suggested in another post.

    I know that it's connecting to Amazon because I tried setting an incorrect Access key ID and Secret key and it gave appropriate error messages, so it's not an authentication issue.

    Finally, I tried changing the CDN type to Amazon S3, I created a Bucket using AWS management Console and that appears to work fine, "Test passed" when I clicked "Test S3 Upload" button. I've not actually published any content to the new S3 bucket as I'd rather use CloudFront.

    Any other suggestions on configuring the CDN using CloudFront?

  2. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    So your server time is correct?

  3. ArchieOpteryx
    Posted 5 years ago #


  4. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    Does the compatibility test indicate that everything is satisfactory for AWS?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic