W3 Total Cache
eAccelerator installed and checked, W3TC says no ... (11 posts)

  1. marky_uk
    Posted 5 years ago #

    Hi there

    Running on WAMP.
    Can see in phpinfo() I get a new section called eAccelerator showing me that is installed and running.

    And at the top of phpinfo() I have "This program makes use of the Zend Scripting Language Engine: Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies with eAccelerator v0.9.6.1, Copyright (c) 2004-2010 eAccelerator, by eAccelerator"

    And my control.php file displays and says it's installed correctly.

    But when I run a compatibility check on a site I get:

    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed

    What gives?

    Thanks in advance :-)


  2. @marky_uk

    eAccelerator removed user cache functions in the 0.9.6 branch. You will need to install version if you want it to work with W3 Total Cache. You can compile from source using the install instructions in the plugin.

  3. marky_uk
    Posted 5 years ago #

    Hi there :-)

    Thanks for taking time to reply.

    I'm a bit thrown by your response though - I'm looking for something that's new/maintained as opposed to something so old. Perhaps I shouldn't be looking to implement eAccelerator at all and look at XCache or APC (if I could find a build for Windows!) ?


  4. @marky_uk,

    The new eAccelerator versions still work in the background you just can't define any user cache settings.

    XCache has Windows binary builds http://xcache.lighttpd.net/wiki/InstallFromBinary

    Not sure about APC for windows but it being maintained and will be included in the next major version of php.

  5. marky_uk
    Posted 5 years ago #

    Hi there

    You say eAccelerator still works ... I saw no speed improvements, and couldn't choose it from the W3TC config screens ... so despite Apache config/info screens telling me it was there, it looked like W3TC wasn't using it ... if that makes sense?

    And re xcache - I'm running php5.3.3 and just tried the install for Windows and PHP 5.3.0 and it's failed (php -v giving runtime errors and not finding the dll despite it being there) so not sure if I should now downgrade php to a previous version and get another dll !


  6. W3 won't use your eAccelerator but php will. W3 won't be able to detect or use it at all.

    I have not experience working with Windows servers my only suggestion would be to move over to Linux.

  7. I wanted to ad that you will probably need to remove eAccelerator before Xcache will work.

  8. marky_uk
    Posted 5 years ago #

    Hi there

    I have removed eAccelerator - does anyone know of a guide that recommends implementing W3 Total Cache on a Windows platform with a suitable caching technology? I've not seen one. If I ever get it working I will probably write one myself on our blog to give to others!

    This is REALLY hard you know. No APC cache build that works, managed to find an eAccelerator build that works and PHP and Apache love ... but W3 Total Cache doesn't like it .. and XCache, as of late yesterday fails to work as I've said above.

    The other problem I've got in another thread re the permissions or something about PREVIEW always showing up (not able to DEPLOY) means I'm not seeing any minified code - so it's a nice looking admin tool just now but nothing else :-)

    So at the moment, I'm 10 days down using W3 Total Cache and it's just not worth having it on!



  9. marky_uk
    Posted 5 years ago #

    OK - comment update time!

    I'VE GOT W3 TOTAL CACHE WORKING WITH XCACHE. If anyone wants to know, let me know, and I'll either post on here on our LogicSpot blog

    Now just got to fix:

    Memcache: Not installed
    Mime type detection: Not installed

    And the preview mode issue with Windows - cannot deploy!

    I will raise separate topics in here for each so I don't hijack this thread off-topic :-)


  10. The other way to deploy is check the box that says: Deselect this option to disable all caching functionality. Then click the disable deploy and save changes.

    You don't need memcahe if your using Xcache.

    For mime type detection use fileinfo. Windows instructions are at the bottom of this page: http://www.php.net/manual/en/fileinfo.installation.php

  11. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    W3TC checks to see if it can store an object in the memory store if it fails, it disables the option. So the checking mechanism is quite simple. Glad you figured it out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic